No SSL Dashboard working after installing mgr crt|key with RSA/4096 secp384r1

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Hello all,

today i got a new certificate for our internal domain based on  RSA/4096
secp384r1. After inserting  CRT and Key i got both "...updated" messages.
After checking the dashboard i got an empty page and this error:

   health: HEALTH_ERR
           Module 'dashboard' has failed: key type unsupported

So we tried to go back to the original state by removing CRT anf KEY but
without success. The new key seems to stuck into the config

[root@cephxxxx ~]# ceph config-key get mgr/dashboard/crt

[root@cephxxxx ~]# ceph config-key get mgr/dashboard/key

*Error ENOENT: *

We tried to generate a self signed Cert but no luck. It looks like manger
stays in an intermediate state. The only way to get back the dashboard is
to disable SSL  and use plain http.

Can somebody explain this behaviour?  Maybe secp384r1 elliptic curves
aren't supported? How can we clean up SSL configuration?

Christoph Ackermann

Ps we checked some Information like and others  but  no
ceph-users mailing list -- ceph-users@xxxxxxx
To unsubscribe send an email to ceph-users-leave@xxxxxxx

[Index of Archives]     [Information on CEPH]     [Linux Filesystem Development]     [Ceph Development]     [Ceph Large]     [Ceph Dev]     [Linux USB Development]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [xfs]

  Powered by Linux