Issue with radosgw-admin reshard when bucket belongs to user with tenant on ceph quincy (17.2.6)

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Hi everybody,

I tried to reshard a bucket belonging to the tenant "test-tenant", but got an "No such file or directory" error.

$ radosgw-admin reshard add --bucket test-tenant/test-bucket --num-shards 40

$ radosgw-admin reshard process
2023-10-04T12:12:52.470+0200 7f654237afc0  0 process_single_logshard: Error during resharding bucket test-tenant/test-bucket:(2) No such file or directory

$ radosgw-admin reshard list
        "time": "2023-10-04T10:12:46.528741Z",
        "tenant": "",
        "bucket_name": "test-tenant/test-bucket",
        "bucket_id": "43e570fd-7573-403f-ab86-a75e12e60146.24142.3",
        "new_instance_id": "",
        "old_num_shards": 23,
        "tentative_new_num_shards": 40

(I also tried --bucket test-bucket)

I then tried to remove the incomplete reshard-job

$ radosgw-admin reshard cancel --bucket  test-tenant/test-bucket
$ radosgw-admin reshard list

$ radosgw-admin reshard process
2023-10-04T12:33:04.251+0200 7fb728e16fc0  0 INFO: RGWReshardLock::lock found lock on reshard.0000000000 to be held by another RGW process; skipping for now


$ radosgw-admin lc reshard fix --bucket  test-tenant/test-bucket

and restarting the rgw containers, I could get rid of the reshard.0000000000 lock.

Unfortunately updating to the latest 17.2 version did not help.

$ ceph orch upgrade start --ceph-version 17.2.6

$ ceph --version
ceph version 17.2.6 (d7ff0d10654d2280e08f1ab989c7cdf3064446a5) quincy (stable)

But after transferring the bucket to a different RGW user without tenant, resharding worked fine:

$ reshard add --bucket test-bucket-without-tenant-user --num-shards 40

$ radosgw-admin reshard process
2023-10-04T12:44:43.599+0200 7f75c908ffc0  1 execute INFO: reshard of bucket "test-bucket-without-tenant-user" from "test-bucket-without-tenant-user:43e570fd-7573-403f-ab86-a75e12e60146.74748.1" to "test-bucket-without-tenant-user:43e570fd-7573-403f-ab86-a75e12e60146.74819.1" completed successfully

This solved my problem, but I wanted to report it, as it may affect other installations too.

Is this problem known? I could not find information for this.
ceph-users mailing list -- ceph-users@xxxxxxx
To unsubscribe send an email to ceph-users-leave@xxxxxxx

[Index of Archives]     [Information on CEPH]     [Linux Filesystem Development]     [Ceph Development]     [Ceph Large]     [Ceph Dev]     [Linux USB Development]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [xfs]

  Powered by Linux