Hi, On 2/28/2025 8:33 AM, Emil Tsalapatis wrote: > Add a helper kfunc that sets the bitmap of a bpf_cpumask from BPF > memory. > > Signed-off-by: Emil Tsalapatis (Meta) <emil@xxxxxxxxxxxxxxx> > --- > kernel/bpf/cpumask.c | 21 +++++++++++++++++++++ > 1 file changed, 21 insertions(+) > > diff --git a/kernel/bpf/cpumask.c b/kernel/bpf/cpumask.c > index cfa1c18e3a48..a13839b3595f 100644 > --- a/kernel/bpf/cpumask.c > +++ b/kernel/bpf/cpumask.c > @@ -420,6 +420,26 @@ __bpf_kfunc u32 bpf_cpumask_weight(const struct cpumask *cpumask) > return cpumask_weight(cpumask); > } > > +/** > + * bpf_cpumask_fill() - Populate the CPU mask from the contents of > + * a BPF memory region. > + * > + * @cpumask: The cpumask being populated. > + * @src: The BPF memory holding the bit pattern. > + * @src__sz: Length of the BPF memory region in bytes. > + * > + */ > +__bpf_kfunc int bpf_cpumask_fill(struct cpumask *cpumask, void *src, size_t src__sz) > +{ > + /* The memory region must be large enough to populate the entire CPU mask. */ > + if (src__sz < BITS_TO_BYTES(nr_cpu_ids)) > + return -EACCES; > + > + bitmap_copy(cpumask_bits(cpumask), src, nr_cpu_ids); Should we use src__sz < bitmap_size(nr_cpu_ids) instead ? Because in bitmap_copy(), it assumes the size of src should be bitmap_size(nr_cpu_ids). > + > + return 0; > +} > + > __bpf_kfunc_end_defs(); > > BTF_KFUNCS_START(cpumask_kfunc_btf_ids) > @@ -448,6 +468,7 @@ BTF_ID_FLAGS(func, bpf_cpumask_copy, KF_RCU) > BTF_ID_FLAGS(func, bpf_cpumask_any_distribute, KF_RCU) > BTF_ID_FLAGS(func, bpf_cpumask_any_and_distribute, KF_RCU) > BTF_ID_FLAGS(func, bpf_cpumask_weight, KF_RCU) > +BTF_ID_FLAGS(func, bpf_cpumask_fill, KF_RCU) > BTF_KFUNCS_END(cpumask_kfunc_btf_ids) > > static const struct btf_kfunc_id_set cpumask_kfunc_set = {