On 7/9/24 11:59, Jakub Sitnicki wrote: > I've got some cosmetic suggestions. > > Instead of having two helper variants - with and without send_flags - we > could stick to just one and always pass send_flags. For readability I'd > use a constant for "no flags". > > This way we keep the path open to convert > unix_inet_skb_redir_to_connected() to to a loop over a parameter > combination matrix, instead of open-coding multiple calls to > unix_inet_redir_to_connected() for each argument combination. All right, I think I was aiming for a (short term) churn reduction. > It seems doing it the current way, it is way too easy to miss > typos. Pretty sure we have another typo at [1], looks like should be > s/SOCK_DGRAM/SOCK_STREAM/. > > [1] > https://elixir.bootlin.com/linux/v6.10-rc7/source/tools/testing/selftests/bpf/prog_tests/sockmap_listen.c#L1863 Yeah, looks like. I'll add a fix to this series. > See below for what I have in mind. Thanks, got it.