Re: backports spatch question

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On 7/1/21 2:51 PM, Johannes Berg wrote:
On Thu, 2021-07-01 at 14:40 -0700, Ben Greear wrote:

[greearb@v-f34-64 backports]$ spatch --version
spatch version 1.0.8-gf4ba8df-dirty compiled with OCaml version 4.11.1

I just realized I never even tried on my system recently, I'm still on
F33 and have

spatch version 1.0.8-gc1dbb4f-dirty compiled with OCaml version 4.11.1

Could you try some other version? Backports says it needs "at least"
1.0.7 but perhaps only exactly that works?

I tried compiling 1.0.8 tag from github, and it seemed to compile and install
OK, but then it complains about python:

[greearb@v-f34-64 backports]$ spatch --sp-file patches/0001-group-attr/0001-group_attr_class.cocci --dir /tmp/x
init_defs_builtins: /usr/local/bin/../lib/coccinelle/standard.h
Py.find_library: unable to find the Python library [/lib64/ returned Cannot resolve PyImport_Cleanup.
[greearb@v-f34-64 backports]$

I'll try to reproduce my work on a Fedora-33 system, every time I tangle with spatch & friends
it never goes well for me.



Ben Greear <greearb@xxxxxxxxxxxxxxx>
Candela Technologies Inc

To unsubscribe from this list: send the line "unsubscribe backports" in

[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Security]     [Bugtraq]     [Linux]     [Linux OMAP]     [Linux MIPS]     [ECOS]     [Asterisk Internet PBX]     [Linux API]

  Powered by Linux