Re: [PATCH 3/3] backports: support class_groups

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 6-2-2017 13:39, Johannes Berg wrote:
> From: Johannes Berg <johannes.berg@xxxxxxxxx>
> 
> Add a new semantic patch just like for dev_groups to
> support class_groups.
> 
> Change-Id: I114e1a6ed8db901b3aa738a5052721d1da45cae4

Does it make sense to keep the Change-Id: things here?

> Signed-off-by: Johannes Berg <johannes.berg@xxxxxxxxx>
> ---
>  .../0001-group-attr/0003-class_groups.cocci        | 54 ++++++++++++++++++++++
>  1 file changed, 54 insertions(+)
>  create mode 100644 patches/collateral-evolutions/generic/0001-group-attr/0003-class_groups.cocci
> 
> diff --git a/patches/collateral-evolutions/generic/0001-group-attr/0003-class_groups.cocci b/patches/collateral-evolutions/generic/0001-group-attr/0003-class_groups.cocci
> new file mode 100644
> index 000000000000..a4694dd75763
> --- /dev/null
> +++ b/patches/collateral-evolutions/generic/0001-group-attr/0003-class_groups.cocci
> @@ -0,0 +1,54 @@
> +/* see upstream commit ced6473e74867 */
> +
> +@ attribute_group @
> +identifier group;
> +declarer name ATTRIBUTE_GROUPS;
> +@@
> +
> +ATTRIBUTE_GROUPS(group);
> +
> +@script:python attribute_groups_name@
> +group << attribute_group.group;
> +groups;
> +@@
> +coccinelle.groups = group + "_groups"
> +
> +@ class_group @
> +identifier group_class;
> +identifier attribute_groups_name.groups;
> +fresh identifier group_dev_attr = attribute_group.group ## "_dev_attrs";

So how will this work wrt naming scheme. Can we be sure all class_attrs
occurrences in the files we copy are named as such, ie. with _dev_attrs
post-fix?

Regards,
Arend
--
To unsubscribe from this list: send the line "unsubscribe backports" in



[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Security]     [Bugtraq]     [Linux]     [Linux OMAP]     [Linux MIPS]     [ECOS]     [Asterisk Internet PBX]     [Linux API]

  Powered by Linux