Re: Is there a way to submit a one-shot update to an Aur package without becoming the maintainer?

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]



On 11/2/24 11:00 PM, David C. Rankin wrote:
On 11/1/24 1:23 PM, Robin Candau wrote:

You can't update a package without being a maintainer / co-maintainer for it. However, since the package is currently orphaned, you can become the maintainer for it and push the update.

Robin,

  I adopted the package as maintainer and pushed updates to https:// aur.archlinux.org/packages/mongodb44. The package now builds cleanly allowing you to follow what is being built. Output is down to about 6,000 lines of build info with only a few stray warnings, down from well over 100,00 lines of continual warnings spew. The following patches are new:

mongodb-4.4.29-boost-1.86.patch
mongodb-4.4.29-fix-scons.patch
mongodb-4.4.29-no-enterprise.patch
mongodb-4.4.29-redudant-std-move.patch

   The database works well.


Thanks for this :)

  I'd appreciate thoughts on anything else I should fix in the PKGBUILD. I am also unclear whether I should list debugedit as a build dependency -- it being somewhat of a generic dependency. Should it be included as well?

(note: this is a BIG build and can take over an hour with link-time optimizations at -j4 or -j8, the source is about a 50M download from github)


I haven't take a detailed look but, after a quick glance, the PKGBUILD looks generally good. Here are a few details I was able to spot:

- "Previous Maintainer" should be listed as "Contributor" (e.g. `# Contributor: name <email>`) [1]

- No reason to list the -bin variant of the `mongosh` package over the "regular" one in optional dependencies [2]. The former provides the latter already.

- The source currently have a potentially conflicting / too generic name [3]. You should rename it to avoid potential name conflicts with other (packages) sources (e.g. `$pkgname-$pkgver.tar.gz::https://github.com/mongodb/mongo/archive/refs/tags/r$pkgver.tar.gz`).

- Custom variables and functions should be prefixed with a underscore. So the `all-flag-vars()` & the `filter-flags()` functions [4][5] should be called `_all-flag-vars()` & `_filter-flags()` instead.

- No need to `cd` to "${srcdir}" in the various functions (e.g. in [6]), every functions are already executed from that directory.

- I would personally ensure installed binaries [7] are executable / have the correct permission mode by using `install -Dm 755` instead of `install -D`.

As for debugedit, it is a part of the base-devel meta-package [8] and thus should *not* be included as make dependency (as base-devel is assumed installed when building packages with makepkg) [9].

[1] https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=mongodb44#n2
[2] https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=mongodb44#n17
[3] https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=mongodb44#n22
[4] https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=mongodb44#n71
[5] https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=mongodb44#n89
[6] https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=mongodb44#n98
[7] https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=mongodb44#n154
[8] https://archlinux.org/packages/core/any/base-devel/
[9] https://wiki.archlinux.org/title/PKGBUILD#makedepends
--
Regards,
Robin Candau / Antiz

Attachment: OpenPGP_0xFDC3040B92ACA748.asc
Description: OpenPGP public key

Attachment: OpenPGP_signature.asc
Description: OpenPGP digital signature


[Index of Archives]     [Linux Wireless]     [Linux Kernel]     [ATH6KL]     [Linux Bluetooth]     [Linux Netdev]     [Kernel Newbies]     [Share Photos]     [IDE]     [Security]     [Git]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux ATA RAID]     [Samba]     [Device Mapper]

  Powered by Linux