On Mon, Oct 30, 2017 at 09:28:16AM +0100, Sergej Sawazki wrote: > Signed-off-by: Sergej Sawazki <sergej@xxxxxxxxxx> > --- > Changes in v2: > * Refactored debug message. > > sound/soc/codecs/wm8741.c | 12 ++++++++++++ > 1 file changed, 12 insertions(+) > > diff --git a/sound/soc/codecs/wm8741.c b/sound/soc/codecs/wm8741.c > index b8c1940..5571882 100644 > --- a/sound/soc/codecs/wm8741.c > +++ b/sound/soc/codecs/wm8741.c > @@ -351,6 +351,17 @@ static int wm8741_set_dai_fmt(struct snd_soc_dai *codec_dai, > return 0; > } > > +int wm8741_mute(struct snd_soc_dai *codec_dai, int mute) > +{ > + struct snd_soc_codec *codec = codec_dai->codec; > + > + dev_dbg(codec->dev, "wm8741_mute: mute = %d\n", mute); It is still not really normal style to include the function name in the debug messages. How about just "digital mute = %d\n" or something like that? Thanks, Charles _______________________________________________ Alsa-devel mailing list Alsa-devel@xxxxxxxxxxxxxxxx http://mailman.alsa-project.org/mailman/listinfo/alsa-devel