Re: isa_bus: ad1848

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



At Mon, 12 Feb 2007 03:52:03 +0100,
Rene Herman wrote:
> 

> @@ -44,99 +47,111 @@ static char *id[SNDRV_CARDS] = SNDRV_DEF
>  static int enable[SNDRV_CARDS] = SNDRV_DEFAULT_ENABLE;	/* Enable this card */
>  static long port[SNDRV_CARDS] = SNDRV_DEFAULT_PORT;	/* PnP setup */
>  static int irq[SNDRV_CARDS] = SNDRV_DEFAULT_IRQ;	/* 5,7,9,11,12,15 */
> -static int dma1[SNDRV_CARDS] = SNDRV_DEFAULT_DMA;	/* 0,1,3,5,6,7 */
> +static int dma[SNDRV_CARDS] = SNDRV_DEFAULT_DMA;	/* 0,1,3,5,6,7 */

Renaming a module option is a bad idea.  It breaks the compatibility.

> -static struct platform_device *devices[SNDRV_CARDS];
> +static int __devinit snd_ad1848_match(struct device *dev, unsigned int n)
> +{
> +	int match;
> +
> +	match = enable[n];
> +	if (!match)
> +		goto out;
>  
> +	match = port[n] != SNDRV_AUTO_PORT;
> +	if (!match) {
> +		snd_printk(KERN_ERR "%s: please specify port\n", dev->bus_id);
> +		goto out;
> +	}

I feel simply returning 0 would be easier to read.

>  
> -	strcpy(card->driver, "AD1848");
> +	strcpy(card->driver, DEV_NAME);

This name is exported and referred in alsa-lib, that this change
breaks the compatibility again (it's case-sensitive).


Thanks,

Takashi

-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier.
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Alsa-devel mailing list
Alsa-devel@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/alsa-devel

[Index of Archives]     [ALSA User]     [Linux Audio Users]     [Kernel Archive]     [Asterisk PBX]     [Photo Sharing]     [Linux Sound]     [Video 4 Linux]     [Gimp]     [Yosemite News]

  Powered by Linux