On Wed, Mar 15, 2023 at 8:22 PM Philipp Rudo <prudo@xxxxxxxxxx> wrote:
> + if (IS_A_NUMBER(args[optind])) {
wouldn't it be easier to simply add
if (!IS_A_NUMBER(args[optind])) {
optind++;
continue;
}
instead of moving the whole body of the loop inside the if-block. Or
did I miss something?
Thank you for the comment, Philipp.
I saw the similar code style in the task.c, just followed these changes.
But anyway, the above changes also look better to me.
Thanks.
Lianbo
-- Crash-utility mailing list Crash-utility@xxxxxxxxxx https://listman.redhat.com/mailman/listinfo/crash-utility Contribution Guidelines: https://github.com/crash-utility/crash/wiki