Re: NUMA node - Memory Only

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Hi, Andrea
When I tried 
 $ dget

But failed, seems I did not have the public key? This is the message from my system:

dget: using existing libvirt_8.5.0.orig.tar.xz
dget: using existing libvirt_8.5.0.orig.tar.xz.asc
dget: using existing libvirt_8.5.0-1.debian.tar.xz
dscverify: libvirt_8.5.0-1.dsc failed signature check:
gpg: WARNING: no command supplied.  Trying to guess what you mean ...
gpg: Signature made Sun 17 Jul 2022 09:01:01 AM PDT
gpg:                using RSA key 3B8F2DF67895CA9C771232DFF79E1FC5428583AC
gpg:                issuer "eof@xxxxxxxxxx"
gpg: Can't check signature: No public key
Validation FAILED!!

Thank You
Jin Huang

On Thu, Aug 11, 2022 at 6:55 AM Andrea Bolognani <abologna@xxxxxxxxxx> wrote:
On Thu, Aug 11, 2022 at 02:21:18AM -0700, Jin Huang wrote:
> Hi, Andrea
> Thank you for your help, but I did not figure out how to deal with the dsc
> and rebuilding package stuff yet.
> Also, I compiled and installed the libvirt-8.5.0 source code from
> The build command I used is:
> meson build -Dsystem=true -Ddriver_interface=enabled
> -Ddriver_libvirtd=enabled -Ddriver_network=enabled -Ddriver_qemu=enabled
> -Ddriver_remote=enabled -Dnumactl=enabled -Dnumad=enabled
> -Dstorage_disk=enabled
> Now my question is how to start the libvird? My OS is Ubuntu20.
> According to, when I tried # service
> libvirtd stop (or systemctl stop libvirtd.service), under build/src
> directory
> The system reports error: Failed to start/stop libvirtd.service: Unit
> libvirtd.service not found.

As I said in the previous message, I'd rebuild the Debian package
instead of building from source. That way, you should be able to
seamlessly replace the version of libvirt that you had installed from
Ubuntu 20.04's repositories with a newer one.

The steps involved should be roughly

  $ sudo apt-get update
  $ sudo apt-get install -y build-essential
  $ sudo apt-get build-dep -y libvirt

to install the necessary build dependencies, and then

  $ dget
  $ cd libvirt-8.5.0/
  $ dpkg-buildpackage --no-sign

to actually build the package. Assuming there are no errors, you
should end up with a bunch of .deb files that you can install on the
system using apt-get.

Andrea Bolognani / Red Hat / Virtualization

[Index of Archives]     [Virt Tools]     [Lib OS Info]     [Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [KDE Users]

  Powered by Linux