virsh qemu-monitor-command block_resize not working

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Hi List,

some version info:
]# /usr/libexec/qemu-kvm -version
QEMU emulator version 4.2.0
(qemu-kvm-4.2.0-48.module+el8.4.0+534+4680a14e) Copyright (c) 2003-2019
Fabrice Bellard and the QEMU Project developers

]# virsh version
Compiled against library: libvirt 6.0.0
Using library: libvirt 6.0.0
Using API: QEMU 6.0.0
Running hypervisor: QEMU 4.2.0

information about block devices for one specific guest:
]# virsh qemu-monitor-command --hmp info block
/data/kvm/storage/diskimages01/uat-win201202_disk1_C.qcow2 (qcow2)
Attached to:      /machine/peripheral/virtio-disk0/virtio-backend Cache
mode:       writeback

ide0-0-0: [not inserted]
    Attached to:      ide0-0-0
    Removable device: not locked, tray closed

But then, when I want to resize the block device, I just cannot seem to
find the correct device. I tried all of these:

virsh qemu-monitor-command --hmp block_resize
libvirt-2-storage 48G
Error: Cannot find device=libvirt-2-storage nor node_name=

virsh qemu-monitor-command --hmp block_resize
drive-libvirt-2-storage 48G
Error: Cannot find device=drive-libvirt-2-storage nor node_name=

virsh qemu-monitor-command --hmp block_resize
virtio-disk0 48G
Error: Cannot find device=virtio-disk0 nor node_name=

virsh qemu-monitor-command --hmp block_resize
drive-virtio-disk0 48G
Error: Cannot find device=drive-virtio-disk0 nor node_name=

In a previous qemu version this worked (EL 7). Can someone help me out?

Best regards,
Arjen Van Drie,

[Index of Archives]     [Virt Tools]     [Lib OS Info]     [Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [KDE Users]

  Powered by Linux