Third round of porting netdev stuff to FreeBSD. A few words on virNetDevTapCreate() changes since the previous review: - it seems that there's no way to avoid iteration over possible interface names, at least I wasn't able to find fucntions for that available from userland - replaced 255 with IF_MAXUNIT, which appears to be a proper constant for that - if we requested to set tapfd, open the device before rename while we still have the original interface name, as the device entry stays the same, i.e. if we rename tap0 to vnet0, it would be still accessible at /dev/tap0, not /dev/vnet0. Fail if the open() failed Roman Bogorodskiy (4): FreeBSD: implement virNetDevExists() and virNetDevSetName(). Make virNetDevSetupControl() public. FreeBSD: implement virNetDevSetMAC() and virNetDevGetMTU(). FreeBSD: implement virNetDevTapCreate() and virNetDevTapDelete(). src/libvirt_private.syms | 1 + src/util/virnetdev.c | 81 ++++++++++++++++++++++++++++++--- src/util/virnetdev.h | 6 +++ src/util/virnetdevtap.c | 114 +++++++++++++++++++++++++++++++++++++++++++++-- 4 files changed, 192 insertions(+), 10 deletions(-) -- 1.8.0 -- libvir-list mailing list libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list