On 09/06/2012 11:17 PM, Eric Blake wrote: > On 09/06/2012 04:13 AM, Hu Tao wrote: >> In many places we store bitmap info in a chunk of data >> (pointed to by a char *), and have redundant codes to >> set/unset bits. This patch extends virBitmap, and convert >> those codes to use virBitmap in subsequent patches. >> --- > >> >> struct _virBitmap { >> - size_t size; >> - unsigned long *map; >> + size_t size; /* size in bits */ >> + size_t size2; /* size in LONGs */ > > The name 'size2' isn't very descriptive. Maybe we should rename to > s/size/max_bit/ and s/size2/map_len/ for easier reading? If you go with the rename idea, then I'd split this into two patches - one that introduces the new field and names and retrofits all existing functions, but adds no new code other than the use of the new field; and the second that only adds the new functions. -- Eric Blake eblake@xxxxxxxxxx +1-919-301-3266 Libvirt virtualization library http://libvirt.org
Attachment:
signature.asc
Description: OpenPGP digital signature
-- libvir-list mailing list libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list