On 04/05/2010 11:18 AM, Eric Blake wrote: > On 04/04/2010 11:36 AM, Matthias Bolte wrote: >> Also rename ReportError to macvtapError. >> --- >> src/qemu/qemu_conf.c | 2 +- >> src/util/macvtap.c | 63 +++++++++++++++++++++++--------------------------- >> src/util/macvtap.h | 3 +- >> 3 files changed, 31 insertions(+), 37 deletions(-) >> >> +++ b/src/util/macvtap.c >> @@ -49,9 +49,9 @@ >> >> # define VIR_FROM_THIS VIR_FROM_NET >> >> -# define ReportError(conn, code, ...) \ >> - virReportErrorHelper(conn, VIR_FROM_NET, code, __FILE__, \ >> - __FUNCTION__, __LINE__, __VA_ARGS__) >> +# define macvtapError(code, ...) \ >> + virReportErrorHelper(NULL, VIR_FROM_NET, code, __FILE__, \ >> + __FUNCTION__, __LINE__, __VA_ARGS__) > > Missing the corresponding cfg.mk change to match the rename. Serves me right for reviewing this incrementally; I now see you did it later in 29/30. Still, it would probably be better to do the rebase, and include the appropriate cfg.mk portion as part of this patch, in case anyone else bisecting history uses this commit as an example for future renaming. -- Eric Blake eblake@xxxxxxxxxx +1-801-349-2682 Libvirt virtualization library http://libvirt.org
Attachment:
signature.asc
Description: OpenPGP digital signature
-- libvir-list mailing list libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list