Re: [libvirt] [PATCH 25/30] macvtap: Remove virConnectPtr from ReportError

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 04/04/2010 11:36 AM, Matthias Bolte wrote:
> Also rename ReportError to macvtapError.
> ---
>  src/qemu/qemu_conf.c |    2 +-
>  src/util/macvtap.c   |   63 +++++++++++++++++++++++---------------------------
>  src/util/macvtap.h   |    3 +-
>  3 files changed, 31 insertions(+), 37 deletions(-)
> 
> +++ b/src/util/macvtap.c
> @@ -49,9 +49,9 @@
>  
>  # define VIR_FROM_THIS VIR_FROM_NET
>  
> -# define ReportError(conn, code, ...)                                      \
> -        virReportErrorHelper(conn, VIR_FROM_NET, code, __FILE__,          \
> -                               __FUNCTION__, __LINE__, __VA_ARGS__)
> +# define macvtapError(code, ...)                                           \
> +        virReportErrorHelper(NULL, VIR_FROM_NET, code, __FILE__,           \
> +                             __FUNCTION__, __LINE__, __VA_ARGS__)

Missing the corresponding cfg.mk change to match the rename.

>  static int
> -getIfIndex(virConnectPtr conn,
> +getIfIndex(int reportError,

This would be better as bool, not int.

> @@ -713,7 +708,7 @@ openMacvtapTap(virConnectPtr conn,
>      *res_ifname = NULL;
>  
>      if (tgifname) {
> -        if(getIfIndex(NULL, tgifname, &ifindex) == 0) {
> +        if(getIfIndex(0, tgifname, &ifindex) == 0) {

...with uses like this using false rather than 0.

-- 
Eric Blake   eblake@xxxxxxxxxx    +1-801-349-2682
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature

--
libvir-list mailing list
libvir-list@xxxxxxxxxx
https://www.redhat.com/mailman/listinfo/libvir-list

[Index of Archives]     [Virt Tools]     [Libvirt Users]     [Lib OS Info]     [Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [KDE Users]     [Fedora Tools]