On Mon, 2019-04-01 at 12:47 -0400, Cole Robinson wrote: [...] > +virHashTablePtr > +testQemuGetCapsLatest(void) A better name for this would be testQemuGetLatestCaps(), since it's literally calling testQemuGetLatestCapsForArch() over a number of architectures. Incidentally, both these functions could use TEST_QEMU_CAPS_PATH once it's introduced, and lose an hardcoded string and a parameter respectively O:-) [...] > +++ b/tests/testutilsqemu.h > @@ -109,6 +109,7 @@ int testQemuCapsIterate(const char *dirname, > int testQemuInfoSetArgs(struct testQemuInfo *info, > virHashTablePtr capslatest, ...); > void testQemuInfoClear(struct testQemuInfo *info); > +virHashTablePtr testQemuGetCapsLatest(void); Both in the source and in the header file, order this new function right after the existing testQemuGetLatestCapsForArch(). With the function named and placed appropriately, Reviewed-by: Andrea Bolognani <abologna@xxxxxxxxxx> -- Andrea Bolognani / Red Hat / Virtualization -- libvir-list mailing list libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list