Re: [PATCH 07/12] tests: Move testQemuInfo* to testutilsqemu

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Mon, 2019-04-01 at 12:47 -0400, Cole Robinson wrote:
[...]
> +#define TEST_CAPS_PATH abs_srcdir "/qemucapabilitiesdata"

Note to self: rename this to TEST_QEMU_CAPS_PATH, move it to
testutilsqemu.h, and start using it throughout the test suite
instead of repeating the raw string over and over again.

[...]
> @@ -32,6 +32,41 @@ enum {
>      GIC_BOTH,
>  };
>  
> +
> +typedef enum {
> +    ARG_QEMU_CAPS,
> +    ARG_GIC,
> +    ARG_MIGRATE_FROM,
> +    ARG_MIGRATE_FD,
> +    ARG_FLAGS,
> +    ARG_PARSEFLAGS,
> +    ARG_CAPS_ARCH,
> +    ARG_CAPS_VER,
> +    ARG_END,
> +} testQemuInfoArgName;
> +
> +

While the .c file is all over the place, the .h file is almost
entirely consistent in its use of a single empty line rather than
two as vertical separator. Please make sure you follow that pattern.

With that addressed,

  Reviewed-by: Andrea Bolognani <abologna@xxxxxxxxxx>

-- 
Andrea Bolognani / Red Hat / Virtualization

--
libvir-list mailing list
libvir-list@xxxxxxxxxx
https://www.redhat.com/mailman/listinfo/libvir-list



[Index of Archives]     [Virt Tools]     [Libvirt Users]     [Lib OS Info]     [Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [KDE Users]     [Fedora Tools]

  Powered by Linux