Re: Can't add an Autostart login script

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Tue, 2022-06-07 at 22:56 +0100, Patrick O'Callaghan wrote:
> On Tue, 2022-06-07 at 17:49 +0100, Colin J Thomson wrote:
> > On Monday, 6 June 2022 12:38:32 BST Patrick O'Callaghan wrote:
> > > Under System Settings->Workspace->Autostart I've attempted to add a
> > > login script using the drop-down menu. It duly appears in the list.
> > > The script is r/w and I've marked it executable using the Properties
> > > dialogue. However when I exit System Settings and reopen it, the
> > > script has not been added, as if the change was not saved. There is no
> > > Save button, so what am I doing wrong?
> >
> > Interesting,
> > I just created a dummy script (that does nothing) and it is still
> > shown in the
> > list after restarting System Settings. I even logged out as well to
> > test.
> >
> > FWIW my KDE is from zawertun's COPR, related or not I don't know.
> >
> > KDE Applications 22.04.1
> > KDE Plasma Version: 5.24.5
> > KDE Frameworks Version: 5.94.0
> KDE 21.12.22
> Plasma 5.24.5
> Frameworks 5.93.0
> Checked again, and it's definitely happening. I can add an application,
> but not a script. It disappears even if I switch to another settings
> tab and back again.
Likewise just tried this... and it worked fine. The script stays in the system

Does a relevant desktop file get created in your ~/.config/autostart directory?

No idea about the script disappearing from your settings, but I have noticed
that if I set the script permissions to 755 (or similar; so long as the owner
has the 'x' permission set), then the script works fine upon log in. (I used a
simple script that 'echo'ed some text to a file in the home directory.) I
didn't not have to mark it as executable in the system settings.
But, if I create a script and leave the permissions as 644, then it does not
run upon log in. Even if I set it as executable in the system settings, it does
not run. Checking the script permissions directly shows them as still 644. (In
the light of that I'm not sure what the executable tick-box in the system
settings is supposed to do.)

Sorry, not really much help.


John Horne | Senior Operations Analyst | Technology and Information Services
University of Plymouth | Drake Circus | Plymouth | Devon | PL4 8AA | UK

This email and any files with it are confidential and intended solely for the use of the recipient to whom it is addressed. If you are not the intended recipient then copying, distribution or other use of the information contained is strictly prohibited and you should not rely on it. If you have received this email in error please let the sender know immediately and delete it from your system(s). Internet emails are not necessarily secure. While we take every care, University of Plymouth accepts no responsibility for viruses and it is your responsibility to scan emails and their attachments. University of Plymouth does not accept responsibility for any changes made after it was sent. Nothing in this email or its attachments constitutes an order for goods or services unless accompanied by an official order form.
kde mailing list -- kde@xxxxxxxxxxxxxxxxxxxxxxx
To unsubscribe send an email to kde-leave@xxxxxxxxxxxxxxxxxxxxxxx
Fedora Code of Conduct:
List Guidelines:
List Archives:
Do not reply to spam on the list, report it:

[Index of Archives]     [KDE Users]     [Fedora General Discussion]     [Older Fedora Users Mail]     [Fedora Advisory Board]     [Fedora Security]     [Fedora Maintainers]     [Fedora Devel Java]     [Fedora Legacy]     [Fedora Desktop]     [ATA RAID]     [Fedora Marketing]     [Fedora Mentors]     [Fedora Package Announce]     [Fedora Package Review]     [Fedora Music]     [Fedora Packaging]     [Centos]     [Fedora SELinux]     [Fedora Triage]     [Coolkey]     [Yum Users]     [Yosemite Forum]     [Fedora Art]     [Fedora Docs]     [Asterisk PBX]

  Powered by Linux