Issues with repo-font-audit

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Hello everyone,

I am the new maintainer of the gdouros-* fonts [1]. When I took over
the fonts, I was not aware of repo-font-audit (shame on me) and it was
the only check I hadn't run, but these days I had been working on
adding some more fonts from Mr. Douros and I stumbled upon the right
wiki pages, so I went along.

For quite some time, a lot of distros ship the Alexander font, but not
the closely related Anaktoria, Aroania and Asea (this one comes in
Regular, Bold, Italic and Bold Italic), which I want to include. I
wrote up all the necessary files based on the ones I had prepared for
Alexander and made the packages [2],[3],[4]. Two local builds on f21
and f22 were successful, rpmlint only whined about what it thought
were typos and I went on to submit to koji scratch builds for rawhide,
which were also successful.

And then I fed them to repo-font-audit. That gave me an error (fonts
in packages that contain non-font data), a warning (fonts that do not
pass fontlint sanity checks) and a suggestion (fonts with partial
unicode block coverage). I have uploaded the full test results at [5].

Seeing that I could not do anything for the warning and the
suggestion, I tried to figure out what was the cause of the error, but
I did not reach any solid conclusion. What is the problem? Is it the
%doc part of the file, the metadata/fontconfig files or all of them

That got me worried so, I decided to run a check against the other
gdouros fonts [6]. Of the seven fonts, repo-font-audit managed to
check only three of them as it threw some error messages as soon as it
started [7]. I looked around for the same errors and I found only a
bug report in [8] about ttfcoverage trying to divide by zero.
It was closed as irrelevant. Should I file a bug report for that? For
the other three fonts it managed to check, I got the exact same error,
warning and suggestion...

Puzzled as I was, I decided to check the liberation and the droid
fonts and to my surprise, repo-font-audit spat out the following:

P#     t3  t10  t13  t17  t20
1      ‧   2    ‧    2    ‧
2      15  15   ‧    15   6
3      ‧   1    ‧    1    1
4      6   6    ‧    6    4
5      ‧   4    ‧    4    ‧
6      ‧   4    4    4    ‧
7      ‧   4    ‧    4    ‧
8      ‧   4    ‧    4    ‧
Total  21  40   4    40   11

Among the above errors, warnings and suggestions are the three ones
that I kept getting. So, is repo-font-audit an absolutely necessary
part of the font package creation process, or is it more of an
advisory tool and we can get by with just the other checks performed
by fedora-review? Are the fontlint sanity checks from [5] worth taking

And on a slightly different topic, is it absolutely required to create
a wiki page for a font package, before it is accepted for inclusion?

Thank you for your time

fonts mailing list

[Index of Archives]     [Fedora Users]     [Font Configuration]     [Fedora Maintainers]     [Fedora Desktop]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite Forum]     [KDE Users]

  Powered by Linux