Re: xmvn-install No suitable repository found to store the artifact in

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On 03/17/2016 02:10 PM, Enrico Tagliavini wrote:
> Hi there,
> I'm trying to make an RPM package for junixsocket [1] but am hitting a
> wall with xmvn-install (build log trimmed for brevity):
> [WARNING] Skipping installation of artifact
> com.kohlschutter.junixsocket:junixsocket-native:nar:2.0.4: No suitable
> repository found to store the artifact in.

Most likely this artifact should be installed as plain JAR. This can be
done using %mvn_artifact macro.

> As far as I understand this is not a bug [2] because nar is not a
> standard artifact. How do I tell xmvn how to do that? I tried adding
> <?xml version="1.0" encoding="US-ASCII"?>
> <configuration xmlns="";>
>   <repositories>
>       <repository>
>       <id>install-nar</id>
>       <type>SimpleRepository</type>
>       <stereotypes>
>         <stereotype>
>           <type>native</type>
>           <extension>nar</extension>
>           <classifier/>
>         </stereotype>
>       </stereotypes>
>       <configuration>
>         <repositories/>
>       </configuration>
>     </repository>
>     </repositories>
> </configuration>
> to the configuration, but it didn't solved the issue. Honestly I'm
> just wild guessing here, I can't find any example to follow.

If you really want to keep "nar" extension, then you can use the
following custom XMvn configuration which should make XMvn recognize
that extension:

    <!-- Custom repo capable of holding nar artifacts. -->
    <!-- Overrides default installation repository defined in
         /usr/share/xmvn/configuration.xml by prepending custom repo.

This config file should be placed appropriate place (either "Reactor
configuration directory" or "Reactor configuration file" as defined at

Mikolaj Izdebski
Software Engineer, Red Hat
IRC: mizdebsk
java-devel mailing list

[Index of Archives]     [Red Users]     [Fedora Desktop]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [KDE Users]

  Powered by Linux