Re: Modifying Fedora Cloud Base image for Openstack

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Thanks! That was the issue. I've added "selinux-relabel"
to my commands_list.txt and after the image customizing
I can login via SSH to the VM.
Best regards, Dmitry Misharov
Senior Software Quality Engineer
Management & Automation QE
On Friday, 18 June 2021 10:57:20 CEST Vitaly Kuznetsov wrote:
>Dmitry Misharov <misharov@xxxxxxxxxx> writes:
>> Hello, how can I modify it locally and don't break the image? I
>> tried to use virt-customize to install some packages, after that
>> I uploaded the modified image to Openstack and tried to provision
>> a VM from it. The VM provisioned but I cannot access via SSH to
>> the instance. Looks like the network was disabled after virt-customize.
>> Commands I used:
>> virt-customize -v -a Fedora-Cloud-Base-34-1.2.x86_64.qcow2 --commands-from-file command_list.txt
>The usual source of issues is "--selinux-relabel" missing on
>'virt-customize' command line, it may help in your case too. If it
>doesn't work you can try accessing the instance via serial and/or
>mounting instance image and going through the logs. I'd start with
>cloud-init log.

cloud mailing list -- cloud@xxxxxxxxxxxxxxxxxxxxxxx
To unsubscribe send an email to cloud-leave@xxxxxxxxxxxxxxxxxxxxxxx
Fedora Code of Conduct:
List Guidelines:
List Archives:
Do not reply to spam on the list, report it:

[Index of Archives]     [Fedora General Discussion]     [Older Fedora Users Archive]     [Fedora Advisory Board]     [Fedora Security]     [Fedora Devel Java]     [Fedora Legacy]     [Fedora Desktop]     [ATA RAID]     [Fedora Marketing]     [Fedora Mentors]     [Fedora Package Announce]     [Fedora Package Review]     [Fedora Music]     [Fedora Packaging]     [Centos]     [Fedora SELinux]     [Coolkey]     [Yum Users]     [Big List of Linux Books]     [Yosemite News]     [Linux Apps]     [KDE Users]     [Fedora Art]     [Fedora Docs]     [Asterisk PBX]

  Powered by Linux