Modifying Fedora Cloud Base image for Openstack

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Hello, how can I modify it locally and don't break the image? I
tried to use virt-customize to install some packages, after that
I uploaded the modified image to Openstack and tried to provision
a VM from it. The VM provisioned but I cannot access via SSH to
the instance. Looks like the network was disabled after virt-customize.
Commands I used:

virt-customize -v -a Fedora-Cloud-Base-34-1.2.x86_64.qcow2 --commands-from-file command_list.txt

cat command_list.txt
install git-core,git-lfs,podman,buildah,skopeo
copy-in /home/fedora/gitlab-runner:/usr/bin/
chmod 0755:/usr/bin/gitlab-runner

As a workaround I provision an instance from unmodified
image, run some commands and save a snapshot. Later I can use that
snapshot as a base image for VMs. Is there another way to modify
Fedora Cloud Base image without provisioning a VM from it to
a cloud provider?
Best regards, Dmitry Misharov
Senior Software Quality Engineer
Management & Automation QE

cloud mailing list -- cloud@xxxxxxxxxxxxxxxxxxxxxxx
To unsubscribe send an email to cloud-leave@xxxxxxxxxxxxxxxxxxxxxxx
Fedora Code of Conduct:
List Guidelines:
List Archives:
Do not reply to spam on the list, report it:

[Index of Archives]     [Fedora General Discussion]     [Older Fedora Users Archive]     [Fedora Advisory Board]     [Fedora Security]     [Fedora Devel Java]     [Fedora Legacy]     [Fedora Desktop]     [ATA RAID]     [Fedora Marketing]     [Fedora Mentors]     [Fedora Package Announce]     [Fedora Package Review]     [Fedora Music]     [Fedora Packaging]     [Centos]     [Fedora SELinux]     [Coolkey]     [Yum Users]     [Big List of Linux Books]     [Yosemite News]     [Linux Apps]     [KDE Users]     [Fedora Art]     [Fedora Docs]     [Asterisk PBX]

  Powered by Linux