Re: Kernel update has lost XMOS USB hardware

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On 09/07/2021 14:19, Peter Robinson wrote:
Please leave the list on replies.

On Fri, Jul 9, 2021 at 1:30 PM David W. Legg<dwlegg@xxxxxxxxx>  wrote:
On 09/07/2021 12:38, Peter Robinson wrote:
Adding arm@ list back in.

On Fri, Jul 9, 2021 at 12:37 PM Peter Robinson<pbrobinson@xxxxxxxxx>   wrote:
On Fri, Jul 9, 2021 at 12:30 PM David W. Legg<dwlegg@xxxxxxxxx>   wrote:
On 09/07/2021 11:24, Peter Robinson wrote:

On Fri, Jul 9, 2021 at 10:10 AM David W. Legg<dwlegg@xxxxxxxxx>    wrote:
I tried updating my Fedora 34 kernel from-




and it no longer recognises my XMOS USB device:

$ cat /proc/asound/cards

     0 [ALSA           ]: bcm2835_alsa - bcm2835 ALSA
                          bcm2835 ALSA
     1 [vc4hdmi0       ]: vc4-hdmi - vc4-hdmi-0
     2 [vc4hdmi1       ]: vc4-hdmi - vc4-hdmi-1
     4 [H20            ]: USB-Audio - HU300 HiFi 2.0
                          Yunyue Audio HU300 HiFi 2.0 at usb-0000:01:00.0-1.3, high speed

So, device number 4 is missing with the 5.12.14-300 kernel.

Given that the rpi4 is not yet supported, whom should I tell about this apparent bug, please?
What's a "XMOS USB hardware"? I doubt being USB it's specific to the
RPi4, does it work on another devices such as an x86 device? Can you
give more information about the device, what driver does it use when
it worked, what's the output of the lsusb line for it etc.
Thanks, for replying, Peter.

It is the sound card #4 mentioned above, labelled H20. It is a USB to
I2S audio interface to an ES9038 DAC.

I can try it with an x86_64 PC when a new card arrives at some point in
the future.
I don't know what you mean by that.

lsusb says it is this:-

Bus 001 Device 003: ID 20b1:0008 XMOS Ltd HU300 HiFi 2.0

It uses the snd_usb_audio driver, according to lsmod.

Should I just report it on Bugzilla, saying that it is
Do other USB devices work in the RPi?

Was this an upgrade from and older Fedora release at some point in the
past? If so does running rpi-uboot-update and rebooting fix it?
It was a fresh F34 installation some months ago, but with minimal updates.

Last week updated just the kernel and my usb audio card was not recognised.
As asked above do other USB devices still work?

Yesterday, I updated everything, with the same results.
Did you run rpi-uboot-update?

Oops, sorry; yes, other USB devices work, e.g. USB 3.0 disk, plugged into USB 3 socket. The XMOS USB audio device is in a USB 2 socket.

I did not run rpi-uboot-update, because it was not an upgrade from an older release ...

... and yes, the rpi-uboot-update fixes it! Hoorah. Many thanks, Peter. :)

Why did the rpi-uboot-update make a USB device reappear? I thought dnf updates did all that sort of thing nowadays.

Is there some documentation somwhere for rpi-uboot-update, please?

arm mailing list -- arm@xxxxxxxxxxxxxxxxxxxxxxx
To unsubscribe send an email to arm-leave@xxxxxxxxxxxxxxxxxxxxxxx
Fedora Code of Conduct:
List Guidelines:
List Archives:
Do not reply to spam on the list, report it:

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Index of Archives]     [Linux ARM (Vger)]     [Linux ARM]     [ARM Kernel]     [Fedora User Discussion]     [Older Fedora Users Discussion]     [Fedora Advisory Board]     [Fedora Security]     [Fedora Maintainers]     [Fedora Devel Java]     [Fedora Legacy]     [Fedora Desktop]     [ATA RAID]     [Fedora Marketing]     [Fedora Mentors]     [Fedora Package Announce]     [Fedora Package Review]     [Fedora Music]     [Fedora Packaging]     [Centos]     [Fedora SELinux]     [Coolkey]     [Yum Users]     [Tux]     [Yosemite News]     [Linux Apps]     [KDE Users]     [Fedora Tools]     [Fedora Art]     [Fedora Docs]     [Asterisk PBX]

Powered by Linux