coolkey C_Initialize failed

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Seems like something is wrong with loading the coolkey module on SUSE:

For example:

localhost:/opt/pam_pkcs11/bin # pkcs11-tool --module
/opt/coolkey/lib/pkcs11/ -I error: PKCS11 function
C_Initialize failed: rv = CKR_GENERAL_ERROR (0x5)



# ./pkcs11_inspect debug
DEBUG:pam_config.c:245: Using config
file /opt/pam_pkcs11/etc/pam_pkcs11.conf
DEBUG:pkcs11_inspect.c:69: loading pkcs #11 module...
DEBUG:pkcs11_lib.c:950: PKCS #11 module =
DEBUG:pkcs11_lib.c:967: module permissions: uid = 0, gid = 0, mode = 755
DEBUG:pkcs11_lib.c:976: loading
module /usr/lib64/pkcs11/
DEBUG:pkcs11_lib.c:984: getting function list
DEBUG:pkcs11_inspect.c:78: initialising pkcs #11 module...
DEBUG:pkcs11_inspect.c:82: init_pkcs11_module() failed: C_Initialize()
failed: 0x00000005

Now if I test against another pkcs modules like opensc it will
successfully initialize:

opensc module: (working)
localhost:/# /tmp/test-pkcs11 /usr/lib64/
## calling C_Initialize() ... ok
## calling C_Finalize() ... ok

coolkey module: (fails)
localhost:/# /tmp/test-pkcs11 /opt/coolkey/lib/pkcs11/
## calling C_Initialize() ... failed (rv = 0x05)

I have tried both the coolkey module from SUSE repo and one I built out of SVN - both fail with the same error.

Any help is much appreciated.

- Crue
Coolkey-devel mailing list

[Index of Archives]     [Fedora Desktop]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [KDE Users]     [Fedora Women]

  Powered by Linux