Coolkey on CentOS

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


As we're getting more people with 144k CACs, I was interested in getting the patched version of Coolkey running on CentOS 5.5 (since the CentOS project itself won't have it until RHEL pushes it out).  I took the SRPM from Rawhide (coolkey-1.1.0-16.fc14.src.rpm) and was sucessfully able to rebuild and install it on CentOS using the following steps:

$ rpmdev-setuptree
$ rpm -ivh --nomd5 coolkey-1.1.0-16.fc14.src.rpm
$ cd ~/rpmbuild/SPECS
$ rpmbuild -bb coolkey.spec
$ cd ../SPECS/i386
$ sudo rpm -Uvh coolkey-1.1.0-16.i386.rpm

When I run Firefox, with the Coolkey module loaded, Firefox crashes within a couple of second of inserting a CAC into the reader. I see this with both a 144k CAC and an older card that works fine with the regular CentOS Cookey package.  When I ran Firefox from the command line, I saw the following error:

firefox: slot.cpp:2258: CKYStatus Slot::readCACCertificateAppend(CKYBuffer*, CKYSize): Assertion `mOldCAC' failed.
/usr/lib/firefox-3.6/ line 131: 16021 Aborted                 "$prog" ${1+"$@"}

I don't recall offhand how to get Coolkey to output a debug log, but I can do that if it would help.  Any other suggestions would be welcome.

I have had success with using OpenSC 0.11.8 and 144k CACs, however I have one particular user that, for some reason, I can't get OpenSC to recognize his card reader, though Coolkey recognizes it just fine.  But since he has a 144k CAC, the card itself doesn't work.


Coolkey-devel mailing list

[Index of Archives]     [Fedora Desktop]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [KDE Users]     [Fedora Women]

  Powered by Linux