Re: Cool-Key on Solaris

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


According to this link (, there were some recent bug fixes introduced into Coolkey. However, the source listed and linked to here ( is version 1.1.0 from 2007...

Are there more up-to-date sources available for Coolkey? The Jan 2010 bug fix advisory mentioning version 1.1.0-14 for RHEL referenced two bugs that would probably cause similar symptoms to what I'm experiencing on OpenSolaris:

Are there more up-to-date sources I should be attempting to build and install Coolkey from?

On 04/20/10 10:22 AM, Kevin Reinholz wrote:
On 04/20/10 10:03 AM, John Magne wrote:
Yeah it sounds like maybe the module is not getting hit.

Have you tried doing the ldd on the module file to see if there are any missing dependencies?
reinholz@etrenank:~$ ldd /usr/local/lib/pkcs11/ =>     /usr/local/lib/ =>     /lib/ =>     /lib/ =>     /usr/sfw/lib/ =>     /lib/ =>     /usr/sfw/lib/ =>     /lib/

Nothing jumps out as missing..

----- Original Message -----
From: "Kevin Reinholz"<kreinholz@xxxxxxxxx>
To: Coolkey-devel@xxxxxxxxxx
Sent: Monday, April 19, 2010 5:39:22 PM GMT -08:00 US/Canada Pacific
Subject: Re: Cool-Key on Solaris

On 04/20/10 01:30 AM, John Magne wrote:
Here is something to try.

Before starting firefix, set this variable:


Then start firefox in the same terminal.

After the module load fails, you can see if there is something in the log file.

I tried by doing the following:

export COOL_KEY_LOG_FILE=/tmp/cool.log

Then attempting to add /usr/local/lib/pkcs11/ as a
Security Module in Firefox. Unfortunately, the log file was empty/not
created, implying my error is very early in the loading process(?)

I've built pk11util so with some examples I can run some tests on using pk11util.

Thanks for your help!


Coolkey-devel mailing list

Coolkey-devel mailing list

[Index of Archives]     [Fedora Desktop]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [KDE Users]     [Fedora Women]

  Powered by Linux