Name prefix

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Dear all,

I've difficulty using the name prefix in component, so I want to ask for help.
The purpose of using the 'name_prefix' is to put i2c driver name before kcontrol's name.
As you all know, the name of the registered kcontrol is defined const, so I couldn't modify direct.

So I've thought of some ways, but I don't know which one is good.
First, as mentioned above, the name value was take from the struct of driver(snd_soc_component_driver) and the value was added to the name_prefix among the members of the snd_soc_component.
Then, the error occurred on the dapm widgets and route.

  ASoC: no source widget found for CLK_SUPPLY
  ASoC: Failed to add route CLK_SUPPLY -> direct -> DAC

I've registered the 'CLK_SUPPLY' on snd_soc_dapm_widget using macro(SND_SOC_DAPM_SUPPLY).
However, with the addition of the name_prefix, the registered widget could not be found.

Is thee a way to change the name of kcontrol or dapm widget? or the way use the name_prefix, or an example code?


Alsa-user mailing list

[Index of Archives]     [ALSA Devel]     [Linux Audio Users]     [Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]

  Powered by Linux