Nice! I had started on some of this a while ago but never finished it.. > 72 bytes. This means it takes 104 bytes off the size of the struct > xfs_inode, which a 12% reduction in size. This will be a massive win > for systems that cache lots of inodes! How many more inodes can we fit into a slab cache now? Back when I started I noticed it doesn't help us to actually fit more inodes into a 4k page due to the bloated VFS inode. But these days slub actually uses a high order allocations if I remember correctly so it might be more useful. > With this change made, the xfs_icdinode is no long an "in core disk > inode" so I'm wondering whether I should rename it or simply make it > go away altogether and pull the remaining fields straight into the > struct xfs_inode. Any thoughts on new names and/or getting rid of it > woul dbe appreciated. I think it should be merged into the xfs_inode structure soner or later. Another thign I planned but never got to is to move fields into the inode fork that were specific to the attr or data fork. _______________________________________________ xfs mailing list xfs@xxxxxxxxxxx http://oss.sgi.com/mailman/listinfo/xfs