[PATCH 00/14 v5] xfsprogs: Partial OSX support

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi all,

An updated version. This set is intended to put together the current
versions of the individual patches with the exception of a new patch 14,
and rebase it against the current master branch.

Patch 4 contains renaming required by Dave, however I'm not sure
if it is still needed with the changes in patches 2 and 3.

Patch 10 (adding timer) was mentioned that it "doesn't look to work",
but I didn't get a reasoning. The added code, when tested,
really run. For testing it in xfs_repair, I don't have how to
create a large enough FS where the timer would be noticable on OSX.
(Not enough of empty space.)

Cheers,
Jan

CHANGELOG:
v5:
- patch 2 was split into 3 patches, numbered 2, 3 and 4
- in patches 2-4, instead of just prefixing it all, a mixed
  approach was used.
- patch 9 renames the function directly instead of using #define
- patch 11 now adds a simple rename
- patch 12 uses mntinfo instead of dummy code
- in patch 13, make mremap build optional instead of dummy code
- new patch 14 with lstat64


v4:
- added #warning message (patch 1)
- use dummy blkid_get_topology instead of #ifdefs (patch 1)
- fix autoconf (wasn't passing -DENABLE_BLKID flag, lost during
  patch cleaning.) (patch 1)
- remove dependency on linux XATTR_ constants (patch 2)
- add autoconf detection for fsetxattr (patch 4)
- use uuid_t instead of unsigned char (patch 5)
- add a basic timer functionality (patch 8)
- mremap replacement now returns MAP_FAILED (patch 11)



Version 3:
- better commit messages (patch 1)
- formatting fixes (patch 2, 8)
- autoconf updates (patch 6, 7)
- changed default behaviour if BLKID is disabled such that mkfs -f
  is required (patch 11)

Jan Tulak (14):
  xfsprogs: Add a way to compile without blkid
  xfsprogs: Add XATTR_LIST_MAX to OS X headers
  xfsprogs: avoid dependency on Linux XATTR_SIZE_MAX
  xfsprogs: prefix XATTR_LIST_MAX with XFS_
  xfsprogs: Add includes required for OS X builds (delta)
  xfsprogs: Add autoconf check for fsetxattr call
  xfsprogs: uuid changes for OS X
  xfsprogs: Remove conflicting define for OS X
  xfsprogs: change nftw64 to nftw
  xfsprogs: Add a timer implementation for OS X
  xfsprogs: Add statvfs64 for osx
  xfsprogs: make fsr use mntinfo when there is no mntent
  xfsprogs: Make mremap conditional
  xfsprogs: rename lstat64 to lstat for OS X

 configure.ac             |  12 +++++-
 estimate/xfs_estimate.c  |   6 +--
 fsr/Makefile             |   8 ++++
 fsr/xfs_fsr.c            |  85 ++++++++++++++++++++++++++++++++-----
 include/builddefs.in     |  12 +++++-
 include/darwin.h         | 106 ++++++++++++++++++++++++++++++++++++++++-------
 include/xfs.h            |   2 +
 io/mmap.c                |   8 ++++
 libhandle/handle.c       |   4 +-
 libhandle/jdm.c          |   4 +-
 libxfs/xfs_attr_remote.c |   2 +-
 libxfs/xfs_format.h      |  10 ++++-
 m4/package_libcdev.m4    |  26 ++++++++++++
 mkfs/xfs_mkfs.c          |  37 ++++++++++++++++-
 repair/progress.c        |  16 ++++++-
 15 files changed, 298 insertions(+), 40 deletions(-)

-- 
2.4.3

_______________________________________________
xfs mailing list
xfs@xxxxxxxxxxx
http://oss.sgi.com/mailman/listinfo/xfs



[Index of Archives]     [Linux XFS Devel]     [Linux Filesystem Development]     [Filesystem Testing]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux