On Sat, Feb 07, 2015 at 09:40:47AM +1100, Dave Chinner wrote: > On Fri, Feb 06, 2015 at 02:52:48PM -0500, Brian Foster wrote: > > Add sb_spinoalignmt to the superblock to specify sparse inode chunk > > alignment. This also currently represents the minimum allowable sparse > > chunk allocation size. > > > > Signed-off-by: Brian Foster <bfoster@xxxxxxxxxx> > > --- > > fs/xfs/libxfs/xfs_format.h | 6 +++--- > > fs/xfs/libxfs/xfs_sb.c | 4 ++-- > > 2 files changed, 5 insertions(+), 5 deletions(-) > > > > diff --git a/fs/xfs/libxfs/xfs_format.h b/fs/xfs/libxfs/xfs_format.h > > index 8eb7189..051c24d 100644 > > --- a/fs/xfs/libxfs/xfs_format.h > > +++ b/fs/xfs/libxfs/xfs_format.h > > @@ -170,7 +170,7 @@ typedef struct xfs_sb { > > __uint32_t sb_features_log_incompat; > > > > __uint32_t sb_crc; /* superblock crc */ > > - __uint32_t sb_pad; > > + xfs_extlen_t sb_spinoalignmt;/* sparse inode chunk alignment */ > > That's a mounthful. sb_spino_align is a bit easier to read, IMO. > Ok. > > @@ -282,7 +282,7 @@ typedef enum { > > XFS_SBS_LOGSECTLOG, XFS_SBS_LOGSECTSIZE, XFS_SBS_LOGSUNIT, > > XFS_SBS_FEATURES2, XFS_SBS_BAD_FEATURES2, XFS_SBS_FEATURES_COMPAT, > > XFS_SBS_FEATURES_RO_COMPAT, XFS_SBS_FEATURES_INCOMPAT, > > - XFS_SBS_FEATURES_LOG_INCOMPAT, XFS_SBS_CRC, XFS_SBS_PAD, > > + XFS_SBS_FEATURES_LOG_INCOMPAT, XFS_SBS_CRC, XFS_SBS_SPINOALIGNMT, > > XFS_SBS_PQUOTINO, XFS_SBS_LSN, > > XFS_SBS_FIELDCOUNT > > } xfs_sb_field_t; > > These are gone in the for-next tree. > The per-field logging stuff is gone... this apparently still exists. It looks like it goes away as part of the icsb rework so this will drop naturally whenever that goes in. Brian > Cheers, > > Dave. > -- > Dave Chinner > david@xxxxxxxxxxxxx _______________________________________________ xfs mailing list xfs@xxxxxxxxxxx http://oss.sgi.com/mailman/listinfo/xfs