Hello, here is a new version of my patch series which moves i_dquot array from struct inode into filesystem private part of the inode. Thus filesystems which don't need it save 2 pointers in their inodes (would be 3 after we add project quota support into generic quota). The patch series also contains a change to quotactl so that each filesystem can set quota types it supports. This is in the end unrelated change (originally it was necessary for i_dquot moving but in the end I changed things so that it's not anymore). I can move that into a separate series but I was somewhat reluctant to do that since that would mean another 6 one-line patches to the same files we are changing here... If people like the patches, I will queue this series into my tree for the next merge window. For that I'd prefer to get acks from affected fs maintainers (the changes are pretty trivial and I don't feel it's a must but still I'd prefer fs maintainers to ack they are aware of the changes). Honza Changes since v1: * Inode field names are now named enum * Quota type masks now have names like QTYPE_MASK_{USR|GRP|PRJ} instead of opencoding shifts. Changes since v2: * Use ->get_dquots callback instead of inode fields framework * rebased on Linus' tree as of 3.18-rc1 + something. Changes since v3: * Moved bitmask of allowed quota types out of s_dquot into sb itself * Removed pointless #ifdef CONFIG_QUOTA from OCFS2 _______________________________________________ xfs mailing list xfs@xxxxxxxxxxx http://oss.sgi.com/mailman/listinfo/xfs