On Thu, Aug 21, 2014 at 02:30:20PM -0500, Eric Sandeen wrote: > For some reason, the older commit: > > 965c8e5 lseek: the "whence" argument is called "whence" > > lseek: the "whence" argument is called "whence" > > But the kernel decided to call it "origin" instead. > Fix most of the sites. > > left out xfs. So fix xfs. > > Signed-off-by: Eric Sandeen <sandeen@xxxxxxxxxx> > --- Reviewed-by: Brian Foster <bfoster@xxxxxxxxxx> > > diff --git a/fs/xfs/xfs_file.c b/fs/xfs/xfs_file.c > index 1da3b7d..0fe36e4 100644 > --- a/fs/xfs/xfs_file.c > +++ b/fs/xfs/xfs_file.c > @@ -1322,16 +1322,16 @@ STATIC loff_t > xfs_file_llseek( > struct file *file, > loff_t offset, > - int origin) > + int whence) > { > - switch (origin) { > + switch (whence) { > case SEEK_END: > case SEEK_CUR: > case SEEK_SET: > - return generic_file_llseek(file, offset, origin); > + return generic_file_llseek(file, offset, whence); > case SEEK_HOLE: > case SEEK_DATA: > - return xfs_seek_hole_data(file, offset, origin); > + return xfs_seek_hole_data(file, offset, whence); > default: > return -EINVAL; > } > > _______________________________________________ > xfs mailing list > xfs@xxxxxxxxxxx > http://oss.sgi.com/mailman/listinfo/xfs _______________________________________________ xfs mailing list xfs@xxxxxxxxxxx http://oss.sgi.com/mailman/listinfo/xfs