* Dave Chinner <david@xxxxxxxxxxxxx>: > On Sat, Apr 19, 2014 at 03:05:24PM -0400, Eric Whitney wrote: > > Generic/001 fails when run on a file system that does not support byte range > > zeroing. For example, an EOPNOTSUPP failure occurs when the test is run > > on a pre-3.15 extent-mapped file system. The code in the test intended > > to prevent this contains an apparent typo that results in a check for > > fallocate() rather than zero range support. > > > > Signed-off-by: Eric Whitney <enwlinux@xxxxxxxxx> > > --- > > tests/generic/009 | 2 +- > > 1 file changed, 1 insertion(+), 1 deletion(-) > > > > diff --git a/tests/generic/009 b/tests/generic/009 > > index b7b0b3f..65abe3c 100644 > > --- a/tests/generic/009 > > +++ b/tests/generic/009 > > @@ -44,7 +44,7 @@ trap "_cleanup ; exit \$status" 0 1 2 3 15 > > > > # real QA test starts here > > _supported_os Linux > > -_require_xfs_io_falloc "fzero" > > +_require_xfs_io_command "fzero" > > There should be a helper in common/rc for this. i.e. > _require_xfs_io_fzero. There's helpers for everything else. Can you > add the helper and wire the tests up to it properly? > Sure. For naming consistency with the other related helper functions, it looks like we'd want to call this _require_xfs_io_falloc_zero(). I'm happy to change this if I'm mistaken. Patches on the way. Thanks, Eric _______________________________________________ xfs mailing list xfs@xxxxxxxxxxx http://oss.sgi.com/mailman/listinfo/xfs