On Mon, Sep 30, 2013 at 09:37:04AM +1000, Dave Chinner wrote: > From: Dave Chinner <dchinner@xxxxxxxxxx> > > The determination of whether a directory entry contains a dtype > field originally was dependent on the filesystem having CRCs > enabled. This meant that the format for dtype beign enabled could be > determined by checking the directory block magic number rather than > doing a feature bit check. This was useful in that it meant that we > didn't need to pass a struct xfs_mount around to functions that > were already supplied with a directory block header. > > Unfortunately, the introduction of dtype fields into the v4 > structure via a feature bit meant this "use the directory block > magic number" method of discriminating the dirent entry sizes is > broken. Hence we need to convert the places that use magic number > checks to use feature bit checks so that they work correctly and not > by chance. > > The current code works on v4 filesystems only because the dirent > size roundup covers the extra byte needed by the dtype field in the > places where this problem occurs. > > Signed-off-by: Dave Chinner <dchinner@xxxxxxxxxx> Looks fine to me. Reviewed-by: Ben Myers <bpm@xxxxxxx> _______________________________________________ xfs mailing list xfs@xxxxxxxxxxx http://oss.sgi.com/mailman/listinfo/xfs