On Mon, 2013-05-13 at 11:59 +0800, Jeff Liu wrote: > Hi, > > On 05/11/2013 05:21 AM, Chandra Seetharaman wrote: > > Add project quota changes to all the places where group quota field > > is used: > > * add separate project quota members into various structures > > * split project quota and group quotas so that instead of overriding > > the group quota members incore, the new project quota members are > > used instead > > * get rid of usage of the OQUOTA flag incore, in favor of separate > > * group > > and project quota flags. > > * add a project dquot argument to various functions. > > > > No externally visible interfaces changed. > > > > Signed-off-by: Chandra Seetharaman <sekharan@xxxxxxxxxx> <snip> > > @@ -409,7 +421,10 @@ xfs_qm_dqattach_one( > > * be reclaimed as long as we have a ref from inode and we > > * hold the ilock. > > */ > > - dqp = udqhint->q_gdquot; > > + if (type == XFS_DQ_GROUP) > > + dqp = udqhint->q_gdquot; > > + else > > + dqp = udqhint->q_pdquot; > Maybe it's better to: > dqp = "type == XFS_DQ_GROUP" ? udqhint->q_gdquot : > udqhint->q_pdquot; Jeff, "if else" construct is preferred for readability than "? :" construct. So, I am leaving it as is. <snip> _______________________________________________ xfs mailing list xfs@xxxxxxxxxxx http://oss.sgi.com/mailman/listinfo/xfs