On 02/20/2013 04:42 AM, Dmitry Monakhov wrote:
The most common usecase for rename(2) syscall is an atomic replacement of existing file with newer version. But rename_f() rename some existing filename to newly generated (non existing) filename. As result the most important usecase is not covered.
Good catch.
Since rename_f() is already exist in fsstress and it has known behavior, some tests already depends on that behaviour, let's add another operation (replace_f) which invoke rename(2) for two existing entries.
OUT_OF_COMMIT_DISCUSSION: Off course replace_f() break naming convention where fun_name == syscall_f(), but this is the only way I see to introduce new feature and not break other tests. May be it is reasonable to call it rename2_f() ?
I think this possible exposes a bug which was not exposed by before when running for example test 076 and test 083 on both ext4 and xfs.
Suggest this new function is called rename2_() so that we don't change the existing known tests.
Regards --Rich _______________________________________________ xfs mailing list xfs@xxxxxxxxxxx http://oss.sgi.com/mailman/listinfo/xfs