On Thu, Feb 28, 2013 at 10:20:45AM +1100, Dave Chinner wrote: > On Wed, Feb 27, 2013 at 04:37:50PM -0600, Ben Myers wrote: > > Hi Dave, .... > > > + case XFS_BLF_AGFL_BUF: > > > + if (*(__be32 *)bp->b_addr != cpu_to_be32(XFS_AGFL_MAGIC)) { > > > + xfs_warn(mp, "Bad AGFL block magic!"); > > > + ASSERT(0); > > > + } > > > + bp->b_ops = &xfs_agfl_buf_ops; > > > + break; > > > > Your changes for v2 in this section look good. > > Actually, the above hunk is broken. The magic number should only be > checked for CRC enabled filesystems. My current code has this check, > though I thought I fixed that long before I reposted this series... I just realised you're commenting on the original version of the patch series, no the new version I posted a couple of days ago. It is fixed in that version of the patch, so I'm not going totally crazy (yet!).... Can you switch over to the newer version of the patch set? Cheers, Dave. -- Dave Chinner david@xxxxxxxxxxxxx _______________________________________________ xfs mailing list xfs@xxxxxxxxxxx http://oss.sgi.com/mailman/listinfo/xfs