Re: [PATCH 0/6 V4] inode32/inode64 allocation changes

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Fri, Sep 21, 2012 at 04:22:25PM -0500, Ben Myers wrote:
> On Thu, Sep 20, 2012 at 10:32:35AM -0300, Carlos Maiolino wrote:
> > This patch set adds inode64 as the default allocation mode, but also includes 2
> > patches to remove duplicated code and another one to make inode32 able to be
> > remounted.
> > 
> > NOTE: This patch has as dependency "Make inode64 a remountable option" patch.
> > 
> > V4 properly set pagf_metadata in patch 5
> > 
> > V3 has a better factoring of each patch goal, including other dchinner's
> > suggestions in V2. 
> > Also it contains a fix in how m_agirotor reset is made (patch 01) that I've
> > found while doing tests with these patches.
> > 
> > Carlos Maiolino (6):
> >   xfs: Fix m_agirotor reset during AG selection
> >   xfs: make inode64 as the default allocation mode
> >   xfs: reduce code duplication handling inode32/64 options
> >   xfs: Fix mp->m_maxagi update during inode64 remount
> >   xfs: add inode64->inode32 transition into xfs_set_inode32()
> >   xfs: Make inode32 a remountable option
> > 
> >  fs/xfs/xfs_ialloc.c |   2 +-
> >  fs/xfs/xfs_mount.c  |  43 +++----------------
> >  fs/xfs/xfs_super.c  | 117 ++++++++++++++++++++++++++++++++++++++++------------
> >  fs/xfs/xfs_super.h  |   2 +
> >  4 files changed, 99 insertions(+), 65 deletions(-)
> 
> This patch does not apply cleanly on the master branch.  What are you running?

Never mind.  I needed Message-Id: <1345238378-10123-1-git-send-email-cmaiolino@xxxxxxxxxx>

Regards,
	Ben

_______________________________________________
xfs mailing list
xfs@xxxxxxxxxxx
http://oss.sgi.com/mailman/listinfo/xfs


[Index of Archives]     [Linux XFS Devel]     [Linux Filesystem Development]     [Filesystem Testing]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux