Re: [PATCH V3] Make inode64 a remountable option

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Thu, Aug 16, 2012 at 11:39:38PM -0300, Carlos Maiolino wrote:
> +		case Opt_inode64:
> +
> +			for (i = 0; i < mp->m_sb.sb_agcount; i++) {
> +				struct xfs_perag	*pag;
> +
> +				pag = xfs_perag_get(mp, i);
> +				pag->pagi_inodeok = 1;
> +				pag->pagf_metadata = 0;
> +				xfs_perag_put(pag);
> +			}
> +			mp->m_flags &= ~(XFS_MOUNT_32BITINODES |
> +					 XFS_MOUNT_SMALL_INUMS);
> +			mp->m_maxagi = i;

Can you factor this into a little helper?  I hate having lots of code
and especially loops inside of deep switch statements.

_______________________________________________
xfs mailing list
xfs@xxxxxxxxxxx
http://oss.sgi.com/mailman/listinfo/xfs


[Index of Archives]     [Linux XFS Devel]     [Linux Filesystem Development]     [Filesystem Testing]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux