[XFS updates] XFS development tree branch, master, updated. v3.5-rc1-32-g824c313

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "XFS development tree".

The branch, master has been updated
  824c313 xfs: remove xfs_ialloc_find_free
  0d882a3 Prefix IO_XX flags with XFS_IO_XX to avoid namespace colision.
  129dbc9 xfs: remove xfs_inotobp
  475ee41 xfs: merge xfs_itobp into xfs_imap_to_bp
  6b7a03f xfs: handle EOF correctly in xfs_vm_writepage
  69ff282 xfs: implement ->update_time
  96ee34b xfs: fix comment typo of struct xfs_da_blkinfo.
      from  a2dcf5df5f3813a44423d4a5026666e751ec00dd (commit)

Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.

- Log -----------------------------------------------------------------
commit 824c313139c2ce678011bf11c4823a0c99651c1f
Author: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Date:   Wed Jul 4 10:54:45 2012 -0400

    xfs: remove xfs_ialloc_find_free
    
    This function is entirely trivial and only has one caller, so remove it to
    simplify the code.
    
    Signed-off-by: Christoph Hellwig <hch@xxxxxx>
    Reviewed-by: Dave Chinner <dchinner@xxxxxxxxxx>
    Signed-off-by: Ben Myers <bpm@xxxxxxx>

commit 0d882a360b9012bc7a7e921c935774c3fba1bfd9
Author: Alain Renaud <arenaud@xxxxxxx>
Date:   Tue May 22 15:56:21 2012 -0500

    Prefix IO_XX flags with XFS_IO_XX to avoid namespace colision.
    
    Add a XFS_ prefix to IO_DIRECT,XFS_IO_DELALLOC, XFS_IO_UNWRITTEN and
    XFS_IO_OVERWRITE. This to avoid namespace conflict with other modules.
    
    Signed-off-by: Alain Renaud <arenaud@xxxxxxx>
    Reviewed-by: Rich Johnston <rjohnston@xxxxxxx>
    Signed-off-by: Ben Myers <bpm@xxxxxxx>

commit 129dbc9a2d93bab823e57fe47f53d098a0d350f3
Author: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Date:   Tue Jul 3 12:21:51 2012 -0400

    xfs: remove xfs_inotobp
    
    There is no need to keep this helper around, opencoding it in the only
    caller is just as clear.
    
    Signed-off-by: Christoph Hellwig <hch@xxxxxx>
    Reviewed-by: Mark Tinguely <tinguely@xxxxxxx>
    Signed-off-by: Ben Myers <bpm@xxxxxxx>

commit 475ee413f34165f8e6fcd7fbff3a4da1dce48c99
Author: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Date:   Tue Jul 3 12:21:22 2012 -0400

    xfs: merge xfs_itobp into xfs_imap_to_bp
    
    All callers of xfs_imap_to_bp want the dinode pointer, so let's calculate it
    inside xfs_imap_to_bp.  Once that is done xfs_itobp becomes a fairly pointless
    wrapper which can be replaced with direct calls to xfs_imap_to_bp.
    
    Signed-off-by: Christoph Hellwig <hch@xxxxxx>
    Reviewed-by: Mark Tinguely <tinguely@xxxxxxx>
    Signed-off-by: Ben Myers <bpm@xxxxxxx>

commit 6b7a03f03a2f8b1629133e35729eba4727fae3cc
Author: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Date:   Tue Jul 3 12:20:00 2012 -0400

    xfs: handle EOF correctly in xfs_vm_writepage
    
    We need to zero out part of a page which beyond EOF before setting uptodate,
    otherwise, mapread or write will see non-zero data beyond EOF.
    
    Based on the code in fs/buffer.c and the following ext4 commit:
    
      ext4: handle EOF correctly in ext4_bio_write_page()
    
    And yes, I wish we had a good test case for it.
    
    Signed-off-by: Christoph Hellwig <hch@xxxxxx>
    Reviewed-by: Mark Tinguely <tinguely@xxxxxxx>
    Signed-off-by: Ben Myers <bpm@xxxxxxx>

commit 69ff2826117f1cde9a2491be57a578212bca551e
Author: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Date:   Wed Jun 6 17:01:28 2012 -0400

    xfs: implement ->update_time
    
    Use this new method to replace our hacky use of ->dirty_inode.  An additional
    benefit is that we can now propagate errors up the stack.
    
    Signed-off-by: Christoph Hellwig <hch@xxxxxx>
    Reviewed-by: Dave Chinner <dchinner@xxxxxxxxxx>
    Signed-off-by: Ben Myers <bpm@xxxxxxx>

commit 96ee34be7a0965a117080a28b2c0cc6d4ee6adb1
Author: Chen Baozi <baozich@xxxxxxxxx>
Date:   Sat Jul 14 03:38:13 2012 +0800

    xfs: fix comment typo of struct xfs_da_blkinfo.
    
    Fix trivial typo error that has written "It" to "Is".
    
    Signed-off-by: Chen Baozi <baozich@xxxxxxxxx>
    Reviewed-by: Ben Myers <bpm@xxxxxxx>
    Signed-off-by: Ben Myers <bpm@xxxxxxx>

-----------------------------------------------------------------------

Summary of changes:
 fs/xfs/xfs_aops.c        |   67 ++++++++++------
 fs/xfs/xfs_aops.h        |   14 ++--
 fs/xfs/xfs_da_btree.h    |    2 +-
 fs/xfs/xfs_ialloc.c      |    9 +--
 fs/xfs/xfs_inode.c       |  197 +++++++++++++++-------------------------------
 fs/xfs/xfs_inode.h       |    9 +--
 fs/xfs/xfs_iops.c        |   45 +++++++++++
 fs/xfs/xfs_itable.c      |    2 +-
 fs/xfs/xfs_log_recover.c |    2 +-
 fs/xfs/xfs_super.c       |   56 -------------
 fs/xfs/xfs_sync.c        |    4 +-
 fs/xfs/xfs_trace.h       |    2 +-
 12 files changed, 167 insertions(+), 242 deletions(-)


hooks/post-receive
-- 
XFS development tree

_______________________________________________
xfs mailing list
xfs@xxxxxxxxxxx
http://oss.sgi.com/mailman/listinfo/xfs


[Index of Archives]     [Linux XFS Devel]     [Linux Filesystem Development]     [Filesystem Testing]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux