This is an automated email from the git hooks/post-receive script. It was generated because a ref change was pushed to the repository containing the project "XFS development tree". The branch, for-next has been updated c3b2da3 fs: introduce inode operation ->update_time b0b0382 ->encode_fh() API change 77ba787 xfs: switch to proper __bitwise type for KM_... flags 90324cc Merge tag 'writeback' of git://git.kernel.org/pub/scm/linux/kernel/git/wfg/linux dbd5768 vfs: Rename end_writeback() to clear_inode() from 14c26c6a05de138a4fd9a0c05ff8e7435a618324 (commit) Those revisions listed above that are new to this repository have not appeared on any other notification email; so we list those revisions in full, below. - Log ----------------------------------------------------------------- commit c3b2da314834499f34cba94f7053e55f6d6f92d8 Author: Josef Bacik <josef@xxxxxxxxxx> Date: Mon Mar 26 09:59:21 2012 -0400 fs: introduce inode operation ->update_time Btrfs has to make sure we have space to allocate new blocks in order to modify the inode, so updating time can fail. We've gotten around this by having our own file_update_time but this is kind of a pain, and Christoph has indicated he would like to make xfs do something different with atime updates. So introduce ->update_time, where we will deal with i_version an a/m/c time updates and indicate which changes need to be made. The normal version just does what it has always done, updates the time and marks the inode dirty, and then filesystems can choose to do something different. I've gone through all of the users of file_update_time and made them check for errors with the exception of the fault code since it's complicated and I wasn't quite sure what to do there, also Jan is going to be pushing the file time updates into page_mkwrite for those who have it so that should satisfy btrfs and make it not a big deal to check the file_update_time() return code in the generic fault path. Thanks, Signed-off-by: Josef Bacik <josef@xxxxxxxxxx> commit b0b0382bb4904965a9e9fca77ad87514dfda0d1c Author: Al Viro <viro@xxxxxxxxxxxxxxxxxx> Date: Mon Apr 2 14:34:06 2012 -0400 ->encode_fh() API change pass inode + parent's inode or NULL instead of dentry + bool saying whether we want the parent or not. NOTE: that needs ceph fix folded in. Signed-off-by: Al Viro <viro@xxxxxxxxxxxxxxxxxx> commit 77ba78776e90e8de541f13b326e284c74286252f Author: Al Viro <viro@xxxxxxxxxxxxxxxxxx> Date: Mon Apr 2 06:24:04 2012 -0400 xfs: switch to proper __bitwise type for KM_... flags Signed-off-by: Al Viro <viro@xxxxxxxxxxxxxxxxxx> commit 90324cc1b11a211e37eabd8cb863e1a1561d6b1d Merge: fb8b006 169ebd9 Author: Linus Torvalds <torvalds@xxxxxxxxxxxxxxxxxxxx> Date: Mon May 28 09:54:45 2012 -0700 Merge tag 'writeback' of git://git.kernel.org/pub/scm/linux/kernel/git/wfg/linux Pull writeback tree from Wu Fengguang: "Mainly from Jan Kara to avoid iput() in the flusher threads." * tag 'writeback' of git://git.kernel.org/pub/scm/linux/kernel/git/wfg/linux: writeback: Avoid iput() from flusher thread vfs: Rename end_writeback() to clear_inode() vfs: Move waiting for inode writeback from end_writeback() to evict_inode() writeback: Refactor writeback_single_inode() writeback: Remove wb->list_lock from writeback_single_inode() writeback: Separate inode requeueing after writeback writeback: Move I_DIRTY_PAGES handling writeback: Move requeueing when I_SYNC set to writeback_sb_inodes() writeback: Move clearing of I_SYNC into inode_sync_complete() writeback: initialize global_dirty_limit fs: remove 8 bytes of padding from struct writeback_control on 64 bit builds mm: page-writeback.c: local functions should not be exposed globally commit dbd5768f87ff6fb0a4fe09c4d7b6c4a24de99430 Author: Jan Kara <jack@xxxxxxx> Date: Thu May 3 14:48:02 2012 +0200 vfs: Rename end_writeback() to clear_inode() After we moved inode_sync_wait() from end_writeback() it doesn't make sense to call the function end_writeback() anymore. Rename it to clear_inode() which well says what the function really does - set I_CLEAR flag. Signed-off-by: Jan Kara <jack@xxxxxxx> Signed-off-by: Fengguang Wu <fengguang.wu@xxxxxxxxx> ----------------------------------------------------------------------- Summary of changes: fs/xfs/kmem.c | 10 +++++----- fs/xfs/kmem.h | 21 +++++++++++---------- fs/xfs/xfs_export.c | 23 +++++++++-------------- fs/xfs/xfs_file.c | 7 +++++-- fs/xfs/xfs_log.c | 2 +- fs/xfs/xfs_log_priv.h | 2 +- fs/xfs/xfs_super.c | 2 +- fs/xfs/xfs_trans.c | 2 +- fs/xfs/xfs_trans.h | 2 +- 9 files changed, 35 insertions(+), 36 deletions(-) hooks/post-receive -- XFS development tree _______________________________________________ xfs mailing list xfs@xxxxxxxxxxx http://oss.sgi.com/mailman/listinfo/xfs