[XFS updates] XFS development tree branch, for-next, updated. v3.2-rc1-11456-g9006fb9

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "XFS development tree".

The branch, for-next has been updated
  9006fb9 xfs: split and cleanup xfs_log_reserve
  42ceedb xfs: share code for grant head availability checks
  e179840d xfs: share code for grant head wakeups
  23ee3df xfs: share code for grant head waiting
  a79bf2d xfs: add xlog_grant_head_wake_all
  c303c5b xfs: add xlog_grant_head_init
  2849696 xfs: add the xlog_grant_head structure
  14a7235 xfs: remove log space waitqueues
  cfb7cdc xfs: cleanup xfs_log_space_wake
  5b03ff1 xfs: remove xfs_trans_unlocked_item
  3af1de7 xfs: do exact log space wakeups in xlog_ungrant_log_space
  09a423a xfs: split tail_lsn assignments from log space wakeups
  70b5437 xfs: cleanup quota check on disk blocks and inodes reservations
      from  33e0edafd78d83273c14b14501cff063fac528e5 (commit)

Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.

- Log -----------------------------------------------------------------
commit 9006fb91cfdf22812923f0536c7531c429c1aeab
Author: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Date:   Mon Feb 20 02:31:31 2012 +0000

    xfs: split and cleanup xfs_log_reserve
    
    Split the log regrant case out of xfs_log_reserve into a separate function,
    and merge xlog_grant_log_space and xlog_regrant_write_log_space into their
    respective callers.  Also replace the XFS_LOG_PERM_RESERV flag, which easily
    got misused before the previous cleanups with a simple boolean parameter.
    
    Signed-off-by: Christoph Hellwig <hch@xxxxxx>
    Reviewed-by: Mark Tinguely <tinguely@xxxxxxx>
    Reviewed-by: Dave Chinner <dchinner@xxxxxxxxxx>
    Signed-off-by: Ben Myers <bpm@xxxxxxx>

commit 42ceedb3caffe67c4ec0dfbb78ce410832d429b9
Author: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Date:   Mon Feb 20 02:31:30 2012 +0000

    xfs: share code for grant head availability checks
    
    Reviewed-by: Mark Tinguely <tinguely@xxxxxxx>
    Signed-off-by: Christoph Hellwig <hch@xxxxxx>
    Reviewed-by: Dave Chinner <dchinner@xxxxxxxxxx>
    Signed-off-by: Ben Myers <bpm@xxxxxxx>

commit e179840d74606ab1935c83fe5ad9d93c95ddc956
Author: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Date:   Mon Feb 20 02:31:29 2012 +0000

    xfs: share code for grant head wakeups
    
    Reviewed-by: Mark Tinguely <tinguely@xxxxxxx>
    Signed-off-by: Christoph Hellwig <hch@xxxxxx>
    Reviewed-by: Dave Chinner <dchinner@xxxxxxxxxx>
    Signed-off-by: Ben Myers <bpm@xxxxxxx>

commit 23ee3df349b8b8fd153bd02fccf08b31aec5bce3
Author: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Date:   Mon Feb 20 02:31:28 2012 +0000

    xfs: share code for grant head waiting
    
    Reviewed-by: Mark Tinguely <tinguely@xxxxxxx>
    Signed-off-by: Christoph Hellwig <hch@xxxxxx>
    Reviewed-by: Dave Chinner <dchinner@xxxxxxxxxx>
    Signed-off-by: Ben Myers <bpm@xxxxxxx>

commit a79bf2d75b8f96bcdb6714138cd53cb3c358669c
Author: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Date:   Mon Feb 20 02:31:27 2012 +0000

    xfs: add xlog_grant_head_wake_all
    
    Reviewed-by: Mark Tinguely <tinguely@xxxxxxx>
    Signed-off-by: Christoph Hellwig <hch@xxxxxx>
    Reviewed-by: Dave Chinner <dchinner@xxxxxxxxxx>
    Signed-off-by: Ben Myers <bpm@xxxxxxx>

commit c303c5b8c3b8eace41c4fba26205b50c0f8e4ca0
Author: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Date:   Mon Feb 20 02:31:26 2012 +0000

    xfs: add xlog_grant_head_init
    
    Reviewed-by: Mark Tinguely <tinguely@xxxxxxx>
    Signed-off-by: Christoph Hellwig <hch@xxxxxx>
    Reviewed-by: Dave Chinner <dchinner@xxxxxxxxxx>
    Signed-off-by: Ben Myers <bpm@xxxxxxx>

commit 28496968a6ac37c8b8c44b5156e633c581bb8378
Author: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Date:   Mon Feb 20 02:31:25 2012 +0000

    xfs: add the xlog_grant_head structure
    
    Add a new data structure to allow sharing code between the log grant and
    regrant code.
    
    Reviewed-by: Mark Tinguely <tinguely@xxxxxxx>
    Signed-off-by: Christoph Hellwig <hch@xxxxxx>
    Reviewed-by: Dave Chinner <dchinner@xxxxxxxxxx>
    Signed-off-by: Ben Myers <bpm@xxxxxxx>

commit 14a7235fba4302a82d61150eda92ec90d3ae9cfb
Author: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Date:   Mon Feb 20 02:31:24 2012 +0000

    xfs: remove log space waitqueues
    
    The tic->t_wait waitqueues can never have more than a single waiter
    on them, so we can easily replace them with a task_struct pointer
    and wake_up_process.
    
    Reviewed-by: Mark Tinguely <tinguely@xxxxxxx>
    Signed-off-by: Christoph Hellwig <hch@xxxxxx>
    Reviewed-by: Dave Chinner <dchinner@xxxxxxxxxx>
    Signed-off-by: Ben Myers <bpm@xxxxxxx>

commit cfb7cdca0aca5ee2e2ef491284bf1edc3b581885
Author: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Date:   Mon Feb 20 02:31:23 2012 +0000

    xfs: cleanup xfs_log_space_wake
    
    Remove the now unused opportunistic parameter, and use the the
    xlog_writeq_wake and xlog_reserveq_wake helpers now that we don't have
    to care about the opportunistic wakeups.
    
    Reviewed-by: Mark Tinguely <tinguely@xxxxxxx>
    Signed-off-by: Christoph Hellwig <hch@xxxxxx>
    Reviewed-by: Dave Chinner <dchinner@xxxxxxxxxx>
    Signed-off-by: Ben Myers <bpm@xxxxxxx>

commit 5b03ff1b2444ddf7b8084b7505101e97257aff5a
Author: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Date:   Mon Feb 20 02:31:22 2012 +0000

    xfs: remove xfs_trans_unlocked_item
    
    There is no reason to wake up log space waiters when unlocking inodes or
    dquots, and the commit log has no explanation for this function either.
    
    Given that we now have exact log space wakeups everywhere we can assume
    the reason for this function was to paper over log space races in earlier
    XFS versions.
    
    Reviewed-by: Mark Tinguely <tinguely@xxxxxxx>
    Signed-off-by: Christoph Hellwig <hch@xxxxxx>
    Reviewed-by: Dave Chinner <dchinner@xxxxxxxxxx>
    Signed-off-by: Ben Myers <bpm@xxxxxxx>

commit 3af1de753b3caf9fa3762b4b1b85d833c121847e
Author: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Date:   Mon Feb 20 02:31:21 2012 +0000

    xfs: do exact log space wakeups in xlog_ungrant_log_space
    
    The only reason that xfs_log_space_wake had to do opportunistic wakeups
    was that the old xfs_log_move_tail calling convention didn't allow for
    exact wakeups when not updating the log tail LSN.  Since this issue has
    been fixed we can do exact wakeups now.
    
    Reviewed-by: Mark Tinguely <tinguely@xxxxxxx>
    Signed-off-by: Christoph Hellwig <hch@xxxxxx>
    Reviewed-by: Dave Chinner <dchinner@xxxxxxxxxx>
    Signed-off-by: Ben Myers <bpm@xxxxxxx>

commit 09a423a3d6c70905f1090f01aadb8e6abff527ce
Author: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Date:   Mon Feb 20 02:31:20 2012 +0000

    xfs: split tail_lsn assignments from log space wakeups
    
    Currently xfs_log_move_tail has a tail_lsn argument that is horribly
    overloaded: it may contain either an actual lsn to assign to the log tail,
    0 as a special case to use the last sync LSN, or 1 to indicate that no tail
    LSN assignment should be performed, and we should opportunisticly wake up
    at one task waiting for log space even if we did not move the LSN.
    
    Remove the tail lsn assigned from xfs_log_move_tail and make the two callers
    use xlog_assign_tail_lsn instead of the current variant of partially using
    the code in xfs_log_move_tail and partially opencoding it.  Note that means
    we grow an addition lock roundtrip on the AIL lock for each bulk update
    or delete, which is still far less than what we had before introducing the
    bulk operations.  If this proves to be a problem we can still add a variant
    of xlog_assign_tail_lsn that expects the lock to be held already.
    
    Also rename the remainder of xfs_log_move_tail to xfs_log_space_wake as
    that name describes its functionality much better.
    
    Reviewed-by: Mark Tinguely <tinguely@xxxxxxx>
    Signed-off-by: Christoph Hellwig <hch@xxxxxx>
    Reviewed-by: Dave Chinner <dchinner@xxxxxxxxxx>
    Signed-off-by: Ben Myers <bpm@xxxxxxx>

commit 70b5437653d9c6c8de287affd38836cce98ebde5
Author: Mitsuo Hayasaka <mitsuo.hayasaka.hu@xxxxxxxxxxx>
Date:   Mon Feb 6 12:51:05 2012 +0000

    xfs: cleanup quota check on disk blocks and inodes reservations
    
    This patch is a cleanup of quota check on disk blocks and inodes
    reservations, and changes it as follows.
    
    (1) add a total_count variable to store the total number of
        current usages and new reservations for disk blocks and inodes,
        respectively.
    
    (2) make it more readable to check if the local variables softlimit
        and hardlimit are positive. It has been changed as follows.
    	    if (softlimit > 0ULL) -> if (softlimit)
    	    if (hardlimit > 0ULL) -> if (hardlimit)
        This is because they are defined as xfs_qcnt_t which is unsigned.
    
    Signed-off-by: Mitsuo Hayasaka <mitsuo.hayasaka.hu@xxxxxxxxxxx>
    Cc: Ben Myers <bpm@xxxxxxx>
    Cc: Alex Elder <elder@xxxxxxxxxx>
    Cc: Christoph Hellwig <hch@xxxxxx>
    Reviewed-by: Mark Tinguely <tinguely@xxxxxxx>
    Reviewed-by: Christoph Hellwig <hch@xxxxxx>
    Signed-off-by: Ben Myers <bpm@xxxxxxx>

-----------------------------------------------------------------------

Summary of changes:
 fs/xfs/xfs_dquot.c       |   11 -
 fs/xfs/xfs_dquot.h       |    3 +-
 fs/xfs/xfs_iget.c        |   13 +-
 fs/xfs/xfs_inode.h       |    4 +-
 fs/xfs/xfs_inode_item.c  |    6 +-
 fs/xfs/xfs_log.c         |  612 ++++++++++++++++++++--------------------------
 fs/xfs/xfs_log.h         |   16 +-
 fs/xfs/xfs_log_priv.h    |   28 +-
 fs/xfs/xfs_log_recover.c |    4 +-
 fs/xfs/xfs_trace.h       |   22 +-
 fs/xfs/xfs_trans.c       |   31 ++-
 fs/xfs/xfs_trans_ail.c   |   83 +------
 fs/xfs/xfs_trans_buf.c   |   25 +--
 fs/xfs/xfs_trans_dquot.c |   17 +-
 fs/xfs/xfs_trans_priv.h  |    3 -
 15 files changed, 330 insertions(+), 548 deletions(-)


hooks/post-receive
-- 
XFS development tree

_______________________________________________
xfs mailing list
xfs@xxxxxxxxxxx
http://oss.sgi.com/mailman/listinfo/xfs


[Index of Archives]     [Linux XFS Devel]     [Linux Filesystem Development]     [Filesystem Testing]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux