On Tue, 2011-08-23 at 04:28 -0400, Christoph Hellwig wrote: > Unify the ways we add buffers to the delwri queue by always calling > xfs_buf_delwri_queue directly. The xfs_bdwrite functions is removed and > opencoded in its callers, and the two places setting XBF_DELWRI while a > buffer is locked and expecting xfs_buf_unlock to pick it up are converted > to call xfs_buf_delwri_queue directly, too. Also replace the > XFS_BUF_UNDELAYWRITE macro with direct calls to xfs_buf_delwri_dequeue > to make the explicit queuing/dequeuing more obvious. > > Signed-off-by: Christoph Hellwig <hch@xxxxxx> > Reviewed-by: Dave Chinner <dchinner@xxxxxxxxxx> So instead of just marking XBF_DELWRI to flag to signal that the buffer should be queued at unlock time, we now just put it in the queue right away. Seems reasonable. Do you know why enqueueing it was delayed before? In any case: Reviewed-by: Alex Elder <aelder@xxxxxxx> _______________________________________________ xfs mailing list xfs@xxxxxxxxxxx http://oss.sgi.com/mailman/listinfo/xfs