On Thu, Dec 30, 2010 at 02:39:59PM -0600, Alex Elder wrote: > Move the check for short file names out of is_special_dirent() and > into generate_obfuscated_name(). That way the check is more > directly associated with the algorithm that requires it. > > Similarly, move the check for inode == 0, since that case has to do > with storing extended attributes (not files) in the name table. > > As a result, is_special_dirent() is really only focused on whether a > given file is in the lost+found directory. > > Rename is_special_dirent() to reflect its more specific purpose. > > And use a cast to elminate a compile warning in calls to > libxfs_da_hashname(). I think Dave's resync of libxfs takes care of that bit. Either way it really should be a separate patch. Also you've stopped overwriting orphanage_ino if it already exists. I don't think this really matters as we won't have two inodes with the same name below the root inode. Either way it should be documented in the changelog. Otherwise the change looks good, Reviewed-by: Christoph Hellwig <hch@xxxxxx> _______________________________________________ xfs mailing list xfs@xxxxxxxxxxx http://oss.sgi.com/mailman/listinfo/xfs