This is an automated email from the git hooks/post-receive script. It was generated because a ref change was pushed to the repository containing the project "XFS development tree". The branch, master has been updated 489a150 xfs: factor duplicate code in xfs_alloc_ag_vextent_near into a helper 9f9baab xfs: clean up xfs_alloc_ag_vextent_exact ecff71e xfs: simplify xfs_map_at_offset aeea1b1 xfs: refactor xfs_vm_writepage 2fa24f9 xfs: remove the all_bh flag from xfs_convert_page ed1e7b7 xfs: remove xfs_probe_cluster 8ff2957 xfs: simplify xfs_map_blocks a206c81 xfs: kill xfs_iomap 405f804 xfs: cleanup the xfs_iomap_write_* helpers 6ac7248 xfs: a few small tweaks for overwrites in xfs_vm_writepage 221cb25 xfs: remove some dead bio handling code 85da94c xfs: improve mapping type check in xfs_vm_writepage c9f71f5 xfs: untangle phase1 vs phase2 recovery helpers d045094 xfs: refactor xlog_recover_commit_trans d5689ea xfs: use struct list_head for the buf cancel table e2714bf xfs: remove leftovers of old buffer log items in recovery code 576ecb8 xfs: fix exporting with left over 64-bit inodes from 05340d4ab2ec2b6b4962c1c41c6ea8fb550f947b (commit) Those revisions listed above that are new to this repository have not appeared on any other notification email; so we list those revisions in full, below. - Log ----------------------------------------------------------------- commit 489a150f6454e2cd93d9e0ee6d7c5a361844f62a Author: Christoph Hellwig <hch@xxxxxxxxxxxxx> Date: Fri Dec 10 15:04:11 2010 +0000 xfs: factor duplicate code in xfs_alloc_ag_vextent_near into a helper Add a new xfs_alloc_find_best_extent that does a forward/backward search in the allocation btree. That code previously was existed two times in xfs_alloc_ag_vextent_near, once for each search direction. Based on an earlier patch from Dave Chinner. Signed-off-by: Christoph Hellwig <hch@xxxxxx> Signed-off-by: Alex Elder <aelder@xxxxxxx> commit 9f9baab38dacd11fe6095a1e59f3783a305f7020 Author: Christoph Hellwig <hch@xxxxxxxxxxxxx> Date: Fri Dec 10 15:03:57 2010 +0000 xfs: clean up xfs_alloc_ag_vextent_exact Use a goto label to consolidate all block not found cases, and add a tracepoint for them. Also clean up a few whitespace issues. Based on an earlier patch from Dave Chinner. Signed-off-by: Christoph Hellwig <hch@xxxxxx> Signed-off-by: Alex Elder <aelder@xxxxxxx> commit ecff71e677c6d469f525dcf31ada709d5858307c Author: Christoph Hellwig <hch@xxxxxxxxxxxxx> Date: Fri Dec 10 08:42:25 2010 +0000 xfs: simplify xfs_map_at_offset Move the buffer locking into the callers as they need to do it wether they call xfs_map_at_offset or not. Remove the b_bdev assignment, which is already done by get_blocks. Remove the duplicate extent type asserts in xfs_convert_page just before calling xfs_map_at_offset. Signed-off-by: Christoph Hellwig <hch@xxxxxx> Reviewed-by: Dave Chinner <dchinner@xxxxxxxxxx> Signed-off-by: Alex Elder <aelder@xxxxxxx> commit aeea1b1f81800e362a3aca86d769d02e137a8fa7 Author: Christoph Hellwig <hch@xxxxxxxxxxxxx> Date: Fri Dec 10 08:42:24 2010 +0000 xfs: refactor xfs_vm_writepage After the last patches the code for overwrites is the same as for delayed and unwritten extents except that it doesn't need to call xfs_map_at_offset. Take care of that fact to simplify xfs_vm_writepage. The buffer loop now first checks the type of buffer and checks/sets the ioend type, or continues to the next buffer if it's not interesting to us. Only after that we validate the iomap and perform the block mapping if needed, all in common code for the cases where we have to do work. Signed-off-by: Christoph Hellwig <hch@xxxxxx> Reviewed-by: Dave Chinner <dchinner@xxxxxxxxxx> Signed-off-by: Alex Elder <aelder@xxxxxxx> commit 2fa24f92530edaf86c3b5f662464e0d2e3b3e517 Author: Christoph Hellwig <hch@xxxxxxxxxxxxx> Date: Fri Dec 10 08:42:23 2010 +0000 xfs: remove the all_bh flag from xfs_convert_page The all_bh flag is always set when entering the page clustering machinery with a regular written extent, which means the check for it is superflous. Signed-off-by: Christoph Hellwig <hch@xxxxxx> Reviewed-by: Dave Chinner <dchinner@xxxxxxxxxx> Signed-off-by: Alex Elder <aelder@xxxxxxx> commit ed1e7b7e484dfb64168755613d499f32a97409bd Author: Christoph Hellwig <hch@xxxxxxxxxxxxx> Date: Fri Dec 10 08:42:22 2010 +0000 xfs: remove xfs_probe_cluster xfs_map_blocks always calls xfs_bmapi with the XFS_BMAPI_ENTIRE entire flag, which tells it to not cap the extent at the passed in size, but just treat the size as an minimum to map. This means xfs_probe_cluster is entirely useless as we'll always get the whole extent back anyway. Signed-off-by: Christoph Hellwig <hch@xxxxxx> Reviewed-by: Dave Chinner <dchinner@xxxxxxxxxx> Signed-off-by: Alex Elder <aelder@xxxxxxx> commit 8ff2957d581582890693affc09920108a67cb05d Author: Christoph Hellwig <hch@xxxxxxxxxxxxx> Date: Fri Dec 10 08:42:21 2010 +0000 xfs: simplify xfs_map_blocks No need to lock the extent map exclusive when performing an overwrite, we know the extent map must already have been loaded by get_blocks. Apply the non-blocking inode semantics to all mapping types instead of just delayed allocations. Remove the handling of not yet allocated blocks for the IO_UNWRITTEN case - if an extent is marked as unwritten allocated in the buffer it must already have an extent on disk. Add asserts to verify all the assumptions above in debug builds. Signed-off-by: Christoph Hellwig <hch@xxxxxx> Reviewed-by: Dave Chinner <dchinner@xxxxxxxxxx> Signed-off-by: Alex Elder <aelder@xxxxxxx> commit a206c817c864583c44e2f418db8e6c7a000fbc38 Author: Christoph Hellwig <hch@xxxxxxxxxxxxx> Date: Fri Dec 10 08:42:20 2010 +0000 xfs: kill xfs_iomap Opencode the xfs_iomap code in it's two callers. The overlap of passed flags already was minimal and will be further reduced in the next patch. As a side effect the BMAPI_* flags for xfs_bmapi and the IO_* flags for I/O end processing are merged into a single set of flags, which should be a bit more descriptive of the operation we perform. Also improve the tracing by giving each caller it's own type set of tracepoints. Signed-off-by: Christoph Hellwig <hch@xxxxxx> Reviewed-by: Dave Chinner <dchinner@xxxxxxxxxx> Signed-off-by: Alex Elder <aelder@xxxxxxx> commit 405f80429436d38ab4e6b4c0d99861a1f00648fd Author: Christoph Hellwig <hch@xxxxxxxxxxxxx> Date: Fri Dec 10 08:42:19 2010 +0000 xfs: cleanup the xfs_iomap_write_* helpers Remove passing the BMAPI_* flags to these helpers, in xfs_iomap_write_direct the check BMAPI_DIRECT was always true, and in the xfs_iomap_write_delay path is was never checked at all. Remove the nmap return value as we never make use of it. Signed-off-by: Christoph Hellwig <hch@xxxxxx> Reviewed-by: Dave Chinner <dchinner@xxxxxxxxxx> Signed-off-by: Alex Elder <aelder@xxxxxxx> commit 6ac7248ec5f20cb44a063d7c7191b8e0068b5a28 Author: Christoph Hellwig <hch@xxxxxxxxxxxxx> Date: Fri Dec 10 08:42:18 2010 +0000 xfs: a few small tweaks for overwrites in xfs_vm_writepage Don't trylock the buffer. We are the only one ever locking it for a regular file address space, and trylock was only copied from the generic code which did it due to the old buffer based writeout in jbd. Also make sure to only write out the buffer if the iomap actually is valid, because we wouldn't have a proper mapping otherwise. In practice we will never get an invalid mapping here as the page lock guarantees truncate doesn't race with us, but better be safe than sorry. Also make sure we allocate a new ioend when crossing boundaries between mappings, just like we do for delalloc and unwritten extents. Again this currently doesn't matter as the I/O end handler only cares for the boundaries for unwritten extents, but this makes the code fully correct and the same as for delalloc/unwritten extents. Signed-off-by: Christoph Hellwig <hch@xxxxxx> Reviewed-by: Dave Chinner <dchinner@xxxxxxxxxx> Signed-off-by: Alex Elder <aelder@xxxxxxx> commit 221cb2517e8fc9a1d67c7a8a9c19fc5a916b583f Author: Christoph Hellwig <hch@xxxxxxxxxxxxx> Date: Fri Dec 10 08:42:17 2010 +0000 xfs: remove some dead bio handling code We'll never have BIO_EOPNOTSUPP set after calling submit_bio as this can only happen for discards, and used to happen for barriers, none of which is every submitted by xfs_submit_ioend_bio. Also remove the loop around bio_alloc as it will never fail due to it's mempool backing. Signed-off-by: Christoph Hellwig <hch@xxxxxx> Reviewed-by: Dave Chinner <dchinner@xxxxxxxxxx> Signed-off-by: Alex Elder <aelder@xxxxxxx> commit 85da94c6b4666582c38579ccdcd90a5d9b5697ef Author: Christoph Hellwig <hch@xxxxxxxxxxxxx> Date: Fri Dec 10 08:42:16 2010 +0000 xfs: improve mapping type check in xfs_vm_writepage Currently we only refuse a "read-only" mapping for writing out unwritten and delayed buffers, and refuse any other for overwrites. Improve the checks to require delalloc mappings for delayed buffers, and unwritten extent mappings for unwritten extents. Signed-off-by: Christoph Hellwig <hch@xxxxxx> Reviewed-by: Dave Chinner <dchinner@xxxxxxxxxx> Signed-off-by: Alex Elder <aelder@xxxxxxx> commit c9f71f5fc4390ea3a8087c00d53a799e7e0f0f8e Author: Christoph Hellwig <hch@xxxxxxxxxxxxx> Date: Wed Dec 1 22:06:24 2010 +0000 xfs: untangle phase1 vs phase2 recovery helpers Dispatch to a different helper for phase1 vs phase2 in xlog_recover_commit_trans instead of doing it in all the low-level functions. Signed-off-by: Christoph Hellwig <hch@xxxxxx> Signed-off-by: Alex Elder <aelder@xxxxxxx> commit d0450948641b2090b5d467ba638bbebd40b20b21 Author: Christoph Hellwig <hch@xxxxxxxxxxxxx> Date: Wed Dec 1 22:06:23 2010 +0000 xfs: refactor xlog_recover_commit_trans Merge the call to xlog_recover_reorder_trans and the loop over the recovery items from xlog_recover_do_trans into xlog_recover_commit_trans, and keep the switch statement over the log item types as a separate helper. Signed-off-by: Christoph Hellwig <hch@xxxxxx> Signed-off-by: Alex Elder <aelder@xxxxxxx> commit d5689eaa0ac5588cf459ee32f86d5700dd7d6403 Author: Christoph Hellwig <hch@xxxxxxxxxxxxx> Date: Wed Dec 1 22:06:22 2010 +0000 xfs: use struct list_head for the buf cancel table Signed-off-by: Christoph Hellwig <hch@xxxxxx> Signed-off-by: Alex Elder <aelder@xxxxxxx> commit e2714bf8d5c8e131a6df6b0ea2269433e9a03a9b Author: Christoph Hellwig <hch@xxxxxxxxxxxxx> Date: Wed Dec 1 22:06:21 2010 +0000 xfs: remove leftovers of old buffer log items in recovery code XFS used to support different types of buffer log items long time ago. Remove the switch statements checking the log item type in various buffer recovery helpers that were left over from those days and the rather useless xlog_recover_do_buffer_pass2 wrapper. Signed-off-by: Christoph Hellwig <hch@xxxxxx> Signed-off-by: Alex Elder <aelder@xxxxxxx> commit 576ecb8e2b725726471cc62b12c01e28d33127ba Author: Samuel Kvasnica <samuel.kvasnica@xxxxxxxxx> Date: Fri Nov 19 13:38:49 2010 +0000 xfs: fix exporting with left over 64-bit inodes We now support mounting and using filesystems with 64-bit inodes even when not mounted with the inode64 option (which now only controls if we allocate new inodes in that space or not). Make sure we always use large NFS file handles when exporting a filesystem that may contain 64-bit inodes. Note that this only affects newly generated file handles, any outstanding 32-bit file handle is still accepted. [hch: the comment and commit log are mine, the rest is from a patch snipplet from Samuel] Signed-off-by: Christoph Hellwig <hch@xxxxxx> Signed-off-by: Alex Elder <aelder@xxxxxxx> ----------------------------------------------------------------------- Summary of changes: fs/xfs/linux-2.6/xfs_aops.c | 425 ++++++++++++------------------ fs/xfs/linux-2.6/xfs_aops.h | 16 ++ fs/xfs/linux-2.6/xfs_export.c | 12 +- fs/xfs/linux-2.6/xfs_trace.h | 29 ++- fs/xfs/xfs_alloc.c | 351 ++++++++++--------------- fs/xfs/xfs_buf_item.h | 11 - fs/xfs/xfs_iomap.c | 149 +---------- fs/xfs/xfs_iomap.h | 27 +-- fs/xfs/xfs_log_priv.h | 6 +- fs/xfs/xfs_log_recover.c | 585 ++++++++++++++++------------------------- 10 files changed, 606 insertions(+), 1005 deletions(-) hooks/post-receive -- XFS development tree _______________________________________________ xfs mailing list xfs@xxxxxxxxxxx http://oss.sgi.com/mailman/listinfo/xfs