On Wed, Dec 01, 2010 at 07:59:20AM -0500, Christoph Hellwig wrote: > On Mon, Nov 29, 2010 at 12:38:26PM +1100, Dave Chinner wrote: > > From: Dave Chinner <dchinner@xxxxxxxxxx> > > > > Convert the log grant heads to atomic64_t types in preparation for > > converting the accounting algorithms to atomic operations. his patch > > just converts the variables; the algorithmic changes are in a > > separate patch for clarity. > > > > Signed-off-by: Dave Chinner <dchinner@xxxxxxxxxx> > > --- > > fs/xfs/linux-2.6/xfs_trace.h | 18 +++++++------ > > fs/xfs/xfs_log.c | 54 +++++++++++++++++++++-------------------- > > fs/xfs/xfs_log_priv.h | 4 +- > > fs/xfs/xfs_log_recover.c | 8 +++--- > > 4 files changed, 44 insertions(+), 40 deletions(-) > > > > diff --git a/fs/xfs/linux-2.6/xfs_trace.h b/fs/xfs/linux-2.6/xfs_trace.h > > index d2cdc85..68c3bdd 100644 > > --- a/fs/xfs/linux-2.6/xfs_trace.h > > +++ b/fs/xfs/linux-2.6/xfs_trace.h > > @@ -768,8 +768,8 @@ DECLARE_EVENT_CLASS(xfs_loggrant_class, > > __field(unsigned int, flags) > > __field(void *, reserveq) > > __field(void *, writeq) > > - __field(xfs_lsn_t, grant_reserve_lsn) > > - __field(xfs_lsn_t, grant_write_lsn) > > + __field(xfs_lsn_t, grant_reserve_head) > > + __field(xfs_lsn_t, grant_write_head) > > What about just naming them _head from the beginning? That would > be a tad cleaner. Same for the actual variables in the log, even > if they change the type here. Will do. Cheers, Dave. -- Dave Chinner david@xxxxxxxxxxxxx _______________________________________________ xfs mailing list xfs@xxxxxxxxxxx http://oss.sgi.com/mailman/listinfo/xfs