As mentioned before I think xfs_trans_ichgtime should go into xfs_trans_inode.c/xfs_trans.h. Instead of keeping xfs_ichgtime around for one caller it might be easier to just opencode it similar to what other filesystems do, e.g. just: inode->i_mtime = inode->i_ctime = current_fs_time(inode->i_sb); mark_inode_dirty_sync(inode); there's really no point in doing the check for an actual time change first as it's a relatively rare operation. _______________________________________________ xfs mailing list xfs@xxxxxxxxxxx http://oss.sgi.com/mailman/listinfo/xfs