> - if ((mask & FSX_PROJID) && (fa->fsx_projid > (__uint16_t)-1)) > + if ((mask & FSX_PROJID) && (fa->fsx_projid > (__uint16_t)-1) > + && !xfs_sb_version_hasprojid32bit(&ip->i_mount->m_sb)) I hate to nipick now that this is basically ready, but the normal kernel and XFS style is to keep the operators at the end of the previous line, e.g. if ((mask & FSX_PROJID) && (fa->fsx_projid > (__uint16_t)-1) && !xfs_sb_version_hasprojid32bit(&ip->i_mount->m_sb)) > --- a/fs/xfs/xfs_sb.h > +++ b/fs/xfs/xfs_sb.h > @@ -80,10 +80,12 @@ struct xfs_mount; > #define XFS_SB_VERSION2_RESERVED4BIT 0x00000004 > #define XFS_SB_VERSION2_ATTR2BIT 0x00000008 /* Inline attr rework */ > #define XFS_SB_VERSION2_PARENTBIT 0x00000010 /* parent pointers */ > +#define XFS_SB_VERSION2_PROJID32BIT 0x00000020 /* 32 bit project id */ 0x00000020 is already used by patches to make use inocode for the CI dir hash, and 0x00000040 is used by the NFSv4 ACL patches. Can you take 0x00000080 instead? I'll submit a patch to get the other two into the header so that they won't conflict. Except for these minor bits this looks good, Reviewed-by: Christoph Hellwig <hch@xxxxxx> _______________________________________________ xfs mailing list xfs@xxxxxxxxxxx http://oss.sgi.com/mailman/listinfo/xfs