RE: Missing separator error when building

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


I've worked it out (possibly).
In file .../xc/´lib/freetype2/Imakefile I've removed some
trailing '@@\' from lines in the section with the install target.
This avoids lines with only a '\' in the resulting Makefile.

That made it work.

It must admit I do not have a clue as to what I'm doing, but it worked for now.


-------------- original message below -------------

Trying to build on Solars 10 SPARC. 
XFree86 version 4.7.0 

Using GNU Make, not Sun's make. 

Get this error: 

gmake[3]: Entering directory `/apps/XFree86/v4.7.0/xc/lib/freetype2' 
Makefile:1152: *** missing separator.  Stop. 

Note that the word "separator" in the make lingo means tab character. 

When I look at the Makefile in the freetype2 directory I can see what the problem is. 
There is a section that looks like this: 

        @if [ -f $(DESTDIR)$(INCDIR)/freetype2/ft2build.h ]; then \ 
            (set -x; $(RM) -f $(DESTDIR)$(INCDIR)/freetype2/ft2build.h) \ 

What make is saying is that after a target (in this case 'install') the actions under that target must be indented by a tab character. 

As you can see this is not the case because of those lines with a single initial backslash on them. 

I'm really a newbie on make and the circus around it so I do not know how to proceed. 
I understand that the Makefile in question is generated every time I run the 'make World' command but I'm 
not clever enough to follow the track and pinpoint where this goes wrong. 

thanks for any help you can give. 

XFree86 mailing list

[Index of Archives]     [X Forum]     [Xorg]     [XFree86 Newbie]     [IETF Announce]     [Security]     [Font Config]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux Kernel]

  Powered by Linux